iMac Gbit fail

Discussion in 'Mac OS X Server, Xserve, and Networking' started by abg0201, Nov 4, 2014.

  1. abg0201 macrumors newbie

    Joined:
    Feb 13, 2013
    #1
    Hi all - really struggling with this.
    Ive installed a Cat6 home network which all seams to be working fine, I'm using a TP Link 16 port switch.
    When I plug in my 2009 mac book pro I'm getting Gbit speed reported. However when I take that same patch cable out of the MBP and plug it into the iMac (2011) Im only getting 100 Mbit/s! Same cables, same switch, same ethernet wall ports. Ive tried changing System Preferences > Network > Advanced> Hardware from Automatic to 1000BaseT but then the connection fails. I am at a loss!
    Can anyone help me out please?
    Thanks loads in advance.
    Andy.
     
  2. DeeASee macrumors newbie

    Joined:
    Nov 4, 2014
    #2
    Just a guess, have you tried cleaning out the iMac's ethernet port?

    A typical problem that causes 100Mb/s is when some of the connectors aren't making contact. Gigabit requires all four pairs but 100Mb only requires two.
     
  3. abg0201 thread starter macrumors newbie

    Joined:
    Feb 13, 2013
    #3
    Yes, thought of that but no difference. I'm wondering if it is a hardware fault too :(
     
  4. sevoneone macrumors 6502

    Joined:
    May 16, 2010
    #4
    What happens if you link your iMac and MacBook directly with a patch cable? Both interfaces should come up at 1Gb.

    Have you tried going into Network preferences and manually setting the speed to 1000 mbps instead of automatic? or maybe it is manually set to 100 mbps some how?
     
  5. jdphoto macrumors 6502

    jdphoto

    Joined:
    Jan 13, 2014
    #5
    Have you tried restarting the iMac with the ethernet cable plugged in? See if it renegotiates to the higher speed.
     

Share This Page