iMac graphics failure?!?!

Discussion in 'iMac' started by diafebus, Nov 17, 2014.

  1. diafebus macrumors newbie

    Joined:
    Apr 30, 2012
    #1
    Hi guys!
    I have a late 2009 iMac 27' i7 and on 2012 I installed a 6970m 1gb to be able to use the computer for gaming a little bit more, and it certainly improved enough to run most games on medium-high settings on bootcamp so its super! I'm always checking the temperature and it never surpassed the limit 70ºC but yesterday the computer (doing nothing special, surfing on the net) started to do graphical glitch, screen with purple bars... and all that nasty stuff... When I boot the purple vertical bars appear before the apple logo... so it looks like the graphic... Sometimes it works sometimes it doesn't... I also read that 2011 iMacs have an extended warranty program from apple for faulty graphics, do you think that's applicable to my graphic card since it is apple branded? Or is there any other testing I can do or anything to try to make it work? (On bootcamp now I get a message that AMD drivers doesn't detect the card anymore...)

    Thanks!
     
  2. twoehr macrumors member

    Joined:
    Jul 3, 2013
    Location:
    East Coast US
    #2
    I have a mid 2011 that had those symptoms and the defect you mention. I was under AppleCare, so I had no hurdle in getting it repaired. Assuming you did the video upgrade on your own I wouldn't think Apple would cover you, but if it was done by Apple then I'd think you could be covered under the "recall".
     

Share This Page