iMac grey screen trouble.

Discussion in 'iMac' started by nitynate, Nov 2, 2007.

  1. nitynate macrumors 6502a

    Joined:
    Jan 22, 2006
    Location:
    Clearwater, FL
    #1
    Let me explain, I was using my computer (original 17" iMac Core Duo) and while im browsing the web, my screen turns a light grey.
    I panic and shut him down.
    So, everytime I turn him on, it has the start up chime and boots normally except for the SCREEN IS GREY. DISPLAYS NOTHING.
    The hard disk is viewable and accesable to my Dell notebook on the network.
    The screen is just grey.
    I have unplugged all hardware and tried to zap the PRAM but it doesnt chime more than once.
    This computer is no longer under warrenty, so ANY help is appreciated.
    Thank you!
     
  2. lallenlowe macrumors member

    Joined:
    Oct 29, 2007
    #2
    Warranties my friends

    Well, I hope you find a solution to your problem, make sure you buy a 3 year warranty next time though. The only thing I can think is that maybe some sort of connection was severed, because the computer boots normally, and the backlight still works. Maybe follow the instructions on taking your iMac apart, then see what you can find, although i don't recomend that.
    Do you see the little apple and spinny wheel when you boot up? or is it already just that light gray? Cause if you can see the boot up image, then it is probably a software issue and you should reinstall OS X.
    The final option is to take it down to a Mac repair place, like MacDocs, Simply Apple, the Apple store, or whatever, have them repair it, and jhust pay them for it.
    Sorry man, that's all I got

    lallenlowe
     
  3. nitynate thread starter macrumors 6502a

    Joined:
    Jan 22, 2006
    Location:
    Clearwater, FL
    #3
    Thanks for your help and no, I do not see an apple spinny wheel or anything.
    Just light grey.
    And, thanks but I would like to avoid opening my computer. That's scary.
    Will the genius bar quote me for free?
    :)
     
  4. ale500 macrumors regular

    Joined:
    Jul 9, 2007
    #4
    Backup your stuff using target disk mode and reinstall the OS, maybe the hd went bad. Did you run the hw diagnostics from the installation disk ?, try that first !, later reinstall (do not forget to save your stuff first!)
     
  5. nitynate thread starter macrumors 6502a

    Joined:
    Jan 22, 2006
    Location:
    Clearwater, FL
    #5
    I can't see the screen.
     
  6. FatSweatyBlldog macrumors regular

    Joined:
    Aug 16, 2007
    #6
    But you can see the HD on the network? If you can access the HD, backup your data.

    Once you've backed up the data, try booting from your OS X install discs. If you can't see the screen while booting from install discs, then you likely have a screen/videocard issue, and will likely need tech support to trouble-shoot further.

    Good luck.
     

Share This Page