iMac grey screen

Discussion in 'iMac' started by Jamie-30, Sep 17, 2017.

  1. Jamie-30 macrumors member

    Joined:
    Oct 7, 2011
    #1
    I was reinstalling windows when the iMac froze. Rebooted and now all I get is a grey screen. No apple logo or progress bar. Just grey.


    OS X or windows do not boot.

    I have tried all keyboard options to try and enter recovery or try and boot from usb etc but nothing. Doesn’t even recognise the key presses.

    The only command it responds to is resetting Nvram.

    I have tried with an external keyboard with same results.

    Any ideas please
     
  2. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #2
    Have you tried booting into safe mode? (Holding your shift key from chime on)? For some reason this works with my right shift key and not the left one.
     
  3. bbnck, Sep 17, 2017
    Last edited: Sep 17, 2017

    bbnck macrumors 6502a

    Joined:
    Mar 19, 2009
    #3
    You haven't told us how old your iMac is, but from the symptoms you're describing it sounds like you may need to erase your hard drive and reinstall OS X and Windows. I hope you have a Time Machine backup.

    First, have you tried booting into Safe Mode? When you start up your iMac, hold down the Shift (⇧) key.

    If that doesn't help, try booting into Internet Recovery by holding down Command (⌘) + R. If that does not work, try again holding down Command (⌘) + Option (⌥) + R instead. If none of these shortcuts work, your iMac might have come with a set of installation discs that you need to use instead depending on the age of the machine.

    As a last resort, you might need to boot into Apple Hardware Test to see if a hardware issue is responsible. When you turn on your iMac, hold down the D key. If this does not work, try again by holding down Option (⌥) + D instead.

    Note: If you have a wireless keyboard, you may need to attach a wired keyboard for keys to be registered immediately at start up.
     
  4. Jamie-30 thread starter macrumors member

    Joined:
    Oct 7, 2011
    #4
    I was thinking the same that the hard drive is corrupt.

    I’ve tried all keyboard shortcuts also with an external keyboard and the only one the works is the nvram reset. No others work.

    It is strange that no keyboard shortcuts apart from one work.

    My iMac is late 2011
     

Share This Page

3 September 17, 2017