iMac help!

BimmerNFS

macrumors newbie
Original poster
Feb 21, 2012
26
0
Indiana
Hi all. Need some help with my Late 2009 EMC 2308 iMac. It will not turn on, it only displays a grey screen. There is no Apple logo, no flashing folder, I can not boot to an external drive. I have tried resetting the PRAM. Thought it might be the HDD, but after thinking about it I should get a flashing folder and question mark if it was only the hard drive. Anyone else has this issue, what you did to fix it, or any ideas to fix it? Thanks!
 

Brian Y

macrumors 68040
Oct 21, 2012
3,642
785
Hi all. Need some help with my Late 2009 EMC 2308 iMac. It will not turn on, it only displays a grey screen. There is no Apple logo, no flashing folder, I can not boot to an external drive. I have tried resetting the PRAM. Thought it might be the HDD, but after thinking about it I should get a flashing folder and question mark if it was only the hard drive. Anyone else has this issue, what you did to fix it, or any ideas to fix it? Thanks!
The HDD could still be the problem. If you're comfortable opening it - try disconnecting the HDD. If the HDD is "on it's way" - the SMC can get stuck trying to read it, and you'll never get the flashing question mark (or you'll get it after hours).
 

CH12671

macrumors 6502
Dec 29, 2013
350
0
Southern US
Hold down the D button while you turn the computer on, and it should boot up into apple hardware test, where you should be able to test your hardware and see what's up....
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.