iMac Help!

Discussion in 'Mac Basics and Help' started by DetroitTigers13, Mar 17, 2007.

  1. DetroitTigers13 macrumors newbie

    Mar 17, 2007
    My Aunt had an old iMac computer that she gave to us, and since all of us had a computer except my brother, my Mom gave it to him. Everything was working good-until we tried to install a printer. We put the CD in, but now can't get it out. There is no icon to move to trash (that's how you eject CDs in iMacs), and it won't eject when we manually try to eject it (according to the instructions on the iMac computer "help" section, you take a pin and gently poke it into the "emergency" hole). It still won't work. We called Apple Support, they told us to press a key that has an "apple" on it, and press the letter "E" at the same time, however that didn't work. Does anyone here have expierence with this problem and can tell us what to do? We don't want to take it in as we know it will cost a lot, and we would be better off buying a new one. This is about 5-6 years old (minimum, might be older). Any help is appreciated!
  2. Chris14 macrumors regular


    Aug 13, 2006
    Hamilton, NZ
    which iMac is this?

    Is this one of the old jelly iMacs,
    that came in loads of colors?

    There should be a manual eject button inside the slot loading drive iMacs that you can press with a pin. It is to the right side of the drive.

    Good luck!
  3. ricksbrain macrumors regular

    Aug 31, 2005
    Miami, FL
    Have you tried restarting while holding down the left mouse button? Or while holding the eject key?

    Any idea why it's not recognizing the cd? Also, are you guys sure you need to install drivers for it to work?
  4. eluk macrumors 6502a


    Dec 14, 2006
    East London, UK
    Boot-up and as soon as you hear the startup chime, hold the mouse button down.

    Too slow. :(
  5. Killyp macrumors 68040


    Jun 14, 2006
    Shut down the computer, wait for it to cool down (maybe, 1 hour?) and then start it back up again (make sure it's in a cool place). BEFORE the Apple logo appears in the screen (or smiling Mac, depending on how old this iMac is), press and hold the mouse button (left if you have a multi-buttoned mouse, main one if you have a hockey puck mouse).

    *should* eject the disk. My MacBook Pro refused to let me have a CD back, and I had to leave it off overnight before I could get the CD out again.

Share This Page