iMac i7 received. Dead pixels and dust behind screen, keep or return?

Discussion in 'iMac' started by pixel-vs-pencil, Aug 16, 2010.

  1. pixel-vs-pencil macrumors member

    Joined:
    Jul 25, 2010
    Location:
    London
    #1
    I received my new 27" i7 1TB HD on Friday. I was amazed at how fast the shipping was. I'm in the UK and I was told it would be shipped from China and arrive in a week and a half, but instead it turned up from Ireland the very next day!

    After unboxing it I ran all the tests.. yes, call me a sceptic and tell me I'm looking for trouble! No yellow screen, no grey shadow, no scratches on cds, no dead pixels on photo booth. So far so good. I could swear my Superdrive is making an odd off-key noise when accepting discs, but second opinions tell me it's normal. The Seagate drive can make 'processing' noises every now and then but it doesn't bother me too much. I think in Europe we're stuck with Seagate for 1TB from what I've read here?

    Anyway, when running the pixel test I noticed that there is a small cluster of reflective (inactive or dead?) pixels on the top right corner about 1.5" in from the sides. These aren't visible usually, just when running the pixel test. Also, when changing the display to block white I noticed a speck of dust behind the screen on the bottom left about 2" in from the bottom and side of the screen. The dust kinda irks me a bit, even though it's not in the centre of the screen or anything.

    I just wanted to know if I'm expecting too much? Would this be enough for you to ask for an exchange or am I being way too picky?
     
  2. Northgrove macrumors 65816

    Joined:
    Aug 3, 2010
    #2
    I would certainly not replace a computer with flaws only visible in tests or other situations it will not be used in, given the risk of getting something worse.
     
  3. pixel-vs-pencil thread starter macrumors member

    Joined:
    Jul 25, 2010
    Location:
    London
    #3
    Fair point, but the dust is visible! Granted, it's not right in the centre of the screen but still..
     
  4. Bobjob186 macrumors 6502

    Joined:
    Apr 16, 2005
    Location:
    Laguna Beach
    #4
    return if it's visible! it should not be like that, if people all over the world have perfect ones why shouldn't you.
     
  5. grantmo macrumors member

    Joined:
    Jun 26, 2010
    Location:
    Scotland
    #5
    I have a few dead pixels on my new iMac and I'm getting it replaced. You have paid a lot of money for your computer it should be perfect.
     
  6. iCaleb macrumors 6502

    Joined:
    Apr 26, 2010
    Location:
    USA
    #6
    I am so shocked apple wont make a glass display that is air tight.....dust is annoying because I brought by iMac down to the apple store to clean the dust off behind the screen and when I got it home there was 3 more specs of dust than when I brought it in + for me its a 2 hour drive to the apple store.
     
  7. pixel-vs-pencil thread starter macrumors member

    Joined:
    Jul 25, 2010
    Location:
    London
    #7
    I think it's because the i7 is built to order, they have to take the glass front off to get the chip inside. The other weird thing I've noticed is my screen isn't that bright. The previous i5 I had hurt my eyes unless I had the brightness at about 40%, but this one I can have the brightness at 100% and work for hours on it. Could the backlight be faulty?

    I'm not trying to pick faults, honest!
     
  8. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #8
    pop the glass off and clean it. you'd likely have to do it sooner or later anyway.
     
  9. Northgrove macrumors 65816

    Joined:
    Aug 3, 2010
    #9
    Oh, right. I interpreted this as it was only visible on a full-white screen that you tested with. But yes, e.g. many web pages use a lot of white too, so it could be noticeable there too, of course. Well, do whatever give you a peace of mind -- this is something that has more to do with your tolerance than anything else. ;) If it keeps bothering you, return it.
     
  10. byron_hinson macrumors 6502

    Joined:
    Jun 3, 2003
    #10
    Returned my i7 27" last week in the UK due to dead pixels right in the center. Hoping the one coming tomorrow finally works as it should as this is my third in 2 weeks. I don't hold out much hope, seems you fix one problem then get another each time.
     

Share This Page