imac, imac pro youtube 8k video playback

Discussion in 'iMac' started by vaugha, Aug 15, 2019 at 7:22 AM.

  1. vaugha macrumors 6502a

    Joined:
    Nov 3, 2011
    #1


    My 2019 mbp i9 15" and 2019 mba struggle severely to play. It literally stutters every few seconds which is practically unwatchable.

    On the other hand my 6-year-old i7 4770k w/ rtx 2080 ti pc plays 8k videos like butter. So before going into the store and trying it out myself, I wonder what the experience of other owners are.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    What app are you using to view it?
    Safari?
    Something else?

    What speed is your internet connection?
    Use a test app and post the results here.
     
  3. HappyIntro macrumors regular

    HappyIntro

    Joined:
    Apr 30, 2016
    #3
    I'm not sure what you are going to try out for yourself at the store, could you elaborate? Also I'm not sure if you are comparing your 6-year old PC with its monster GPU and very strong desktop-class CPU to Apple's thin and light laptops. That doesn't seem like a good comparison if so; of course the desktop would smoke any laptop. Maybe I'm missing something.
     
  4. TwoH macrumors newbie

    Joined:
    May 19, 2019
    #4
    Those are MacBooks - and they do not have 8k displays anyway?
     
  5. bpeeps macrumors 68030

    bpeeps

    Joined:
    May 6, 2011
    #5
    Internet speed is going to affect playback the most. I have 200/20 and I couldn't even stream it in 4K. Had to dumb it down to 2160. Beautiful shots by the way, I did Peru in 2016.
     
  6. vaugha thread starter macrumors 6502a

    Joined:
    Nov 3, 2011
    #6
    I have a 1.5gbps/940mbps line and I get around 300/300 on wifi so my internet is not the bottleneck. I‘m gonna try it in a local apple store. Never owned an imac before.
     
  7. CE3, Aug 15, 2019 at 2:42 PM
    Last edited: Aug 15, 2019 at 2:56 PM

    CE3 macrumors 65816

    Joined:
    Nov 26, 2014
    #7
    My iMac with the 3.6 i9 and Radeon 580X played fine in Firefox in all its oversaturated glory (no wide gamut color management). CPU usage, however, went way up and the fans came on about a minute into playback, which hadn't happened before during video streaming/playback.

    I have hyper-threading disabled on the i9.
     
  8. mam8dg macrumors newbie

    Joined:
    Mar 20, 2019
    #8
    Plays fine on my iMac Pro in Google Chrome. I have FIOS Gigabit, using the ethernet port on IMP. I set it to 8k, though IMP screen is 5k.
     
  9. vaugha thread starter macrumors 6502a

    Joined:
    Nov 3, 2011
    #9
    Thx, that's good to know. Been eyeing on the pro for a couple of weeks now. I've been debating whether to get the imp or the new pro display xdr. I will probably wait for the pro display and see it in person and make the decision.
     

Share This Page

8 August 15, 2019