Imac, intel won't start - help pleae

Discussion in 'iMac' started by judderman62, Aug 16, 2010.

  1. judderman62 macrumors newbie

    Joined:
    Jul 27, 2009
    #1
    HI all

    Hoping someone can help - my imac (approx 15-18 months old , intel) won't start.

    Last night on shutting down DPP (canon Digital image software) was hanging and system asked me if I wanted to force quit it...sadly I had switched off my bluetooth mouse and , as usually once mouse turned off switching it back on it never re connects - why did I buy the bletooth mouse and keyboard ?, so I could not confirm yes force quit - is there no way of selecting with keyboard like there is in windows ?

    So I switched off at power switch. Tried to re switch on - grey screen came up, apple logo, the little timer circle but after a while timer circle stopped and nothing further happened.

    have tried several more times and now don't even get timer.

    Can anyone please help :-(

    thanks very much

    J
     
  2. judderman62 thread starter macrumors newbie

    Joined:
    Jul 27, 2009
    #3
    thanks for those - have printed them off and will have a go when I get home.

    thanks very much
     
  3. DannyBres macrumors 65816

    DannyBres

    Joined:
    Oct 30, 2007
    Location:
    UK
    #4
    Im sure you can use the keyboard to select things like windows!
     
  4. judderman62 thread starter macrumors newbie

    Joined:
    Jul 27, 2009
    #5
    didn't work last night :(

    tried tab, tried right arrow, tried up and down arrow (after all Mac like to be different and obtuse)

    None of above worked :(
     
  5. Giuly macrumors 68040

    Giuly

    #6

Share This Page