iMac internet connection problems - SLOW

Discussion in 'iMac' started by junoproject, Sep 16, 2010.

  1. junoproject macrumors newbie

    Joined:
    Sep 16, 2010
    #1
    (I hope this isn't superfluous; I have seen similar problems posted but no solutions that solved this problem, so here goes...)

    I recently bought a 27'' iMac (3.2 GHz Intel Core i3, OSX10.6.4) and all was fine and dandy until yesterday when my internet connection suddenly got very slow. It takes FOREVER to load pages, if they load at all. The rest of the iMac is fine as before, which leads me to conclude this is an internet issue.
    I cleared the cache and browsing history in Google Chrome and no improvement. I tried using Safari and Firefox and they were slow too.
    I also have a MacBookPro (2.2 GHz Intel Core 2 Duo, OSX10.6.4), so I checked the internet speed on that and it was normal. Both MBP and iMac are connected via an Airport Express.
    I searched various forums and threads for a solution, but I know very little when it come to these things so I quickly got stuck in technical jargon.
    I've tried to change the DNS server settings (first to 4.2.2.1 and 4.2.2.2, then to 208.67.222.222 and 208.67.220.220) but this has not helped.

    Does anyone know what has happened here and, more importantly, how to fix it? I am completely stumped! Please help!
     
  2. Hermes Monster macrumors 6502a

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #2
    Try resetting your router, there should be a little button to press with a pen or something

    There's another thread in here too, someone else had a slow browser which turned out to have a corrupted book mark, try uninstalling the browser or using Chrome etc
     
  3. Xodd macrumors regular

    Joined:
    Nov 16, 2009
    #3
    I am also experiencing this at home. I have the imac 21.5" and my internet is dead slow. Adium keeps getting disconnected and pages are mega slow to load up. I end up using bootcamp windows for normal faster internet. It's deffo not a hardware problem. I called Apple care and they i changed the DNS. I'm still experiencing poor internet. Can someone help?
     
  4. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #4
    .

    Unknown to many folks, the new MBP and iMac platforrms don't like to "wireless" with some wireless equipment. Some say its the ISP, some say its the MAC OS, some say its lack of solid handshaking across different vendor products, and some say its for other reasons.

    Regardless, there is a few known fixes for slow access / dropped sessions. They are:


    Customize 1 - Change the MTU size on your MBP. For more details, surf:

    Surf:
    http://help.expedient.com/broadband/mtu.shtml
    http://www.zen.co.uk/Support/Tools.aspx

    Note: See my next post for MTU Recommend/Set program details.

    If wondering, I changed my iMac's MTU size to 1492 (same as my ADSL Modem / Wireless "2Wire 1701 box" MTU "fixed value" size) and it works great. Much, much faster then allowing background "automatic" MTU task.


    Customize 2 - Don't use WEP. Unknown to some, small amount of Mac workstation's don't like WEP (which is Sympatico's suggested) Wireless configuration for Macs. As a suggestion, change to WPA or WPA2 and if possible, enable MAC Address security within your Router as well. Thus, enabling both text "key" and H/W Address security layers. If you must go with WEP (because other wireless devices can only use WEP), do use MAC Address security on your modem / wireless device as well. When you can, use WPA for security settings.

    For more details about WAP2, surf:
    http://www.youtube.com/watch?v=di19ZgVhHH8
    http://www.youtube.com/watch?v=q0ZqQuTYwEk


    Customize 3 - Customize Router defaults.

    With many wireless boxes, their wireless power level default is often set at 5 (10 being max). Set to 8 and "give it a try". Also, the wireless might also be set for both 802.11 B/G (mixed). Set it for 82.11B and "give it a try". If stable, then set to 802.11G. "Give that a try." If wondering, some wireless boxes don't like using B/G mixed with some workstations. If wondering, I set my 2Wire and iMac with "only G" and it works great.


    Customize 4 - Don't use Mac workstation Security - Firewall (for now). For some small number of Mac workstations, Firewall on Home's Router and Firewall on Mac platform can "conflict" with one another. For now, turn Mac's Security-Firewall OFF (if your Modem/Gateway also has Firewall enabled). Only turn Mac workstation's Firewire ON (enabled) when all other things work great.


    If all these customizations fail, one can also change the "delay" values with Mac's SMB.INF file. But that's for advanced users. The above items are "simple changes".


    For 9 times out of 10, the mixture of 802.11B/G and improper MTU settings (default of 1500 value) are the majority of slow, dropped wireless / internet session problems.


    Hope this helps....
     
  5. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #5
    .

    To set MTU within my iMac 21.5" (that can also be used for a MBP), I used a free MTU size Discovery / Set utility. With this tool (saved in my iMac's Applications - Utility folder), I manually set its MTU on all ports (ethernet, wireless, firewire, etc.) only once. Set it once and its done.

    This script can be found at:

    http://tumbleseed.wordpress.com/products/set-mtu/

    Note: Click on its "Download the Set MTU 0.2 script application (zip)" text - to obtain the MTU script file.

    And yes, this script works great on mid-2010 21.5" iMacs using SL as well.

    Hope this helps as well...

    .
     
  6. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #6
    Also...

    Do "double check" your DNS address as well. Incorrect DNS can make web sites very slow as well.

    Also.... If "wired" connection, you may want to configure your Mac with "static" values (instead of default DHCP with AUTO-AUTO). For example, Full Duplex, 100 MPBs, fixed (static) IP Address, fixed (static) Default Gateway and fixed (static) DNS address. If wondering, my iMac is "wired" and uses Fixed values (with adjusted MTU). Its access to internet is now "solid as a rock".

    Hope this helps as well...

    .
     
  7. Hermes Monster macrumors 6502a

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #7
    Good advice, thanks Spike - I'm now wondering if one of those issues could be the cause of my poor iPad wifi connection.

    as you seem to know a lot about wifi/routers can you suggest anything for a SKY Netgear router? I'm getting an iMac shortly and fear I will have these issues! :confused:
     
  8. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #8
    My ISP provided modem (+ wireless combo box) is a 2Wire. re: http://support.2wire.com/ If wondering, 2Wire 1701 modem is very Win xx friendly (for wired and wireless) but at times, it isn't Mac friendly. After some "tweaking" with hard coded values (like MTUs, "only G", etc. etc), my iMac's Internet access become much more stable (and much faster). With my home setup, I simply "set its values" and its good. Good until I change those values or reload its OS. Thus, I'd call it more of a "tweaking" then issues.

    To learn historical and some current "tweaking" with Netgear modems and iMacs, surf many posts within:

    http://www.google.ca/#hl=en&source=...&oq=Netgear+imac&gs_rfai=&fp=7107a4e6866ad609

    Note: Focus on your modem's exact model and how other folks resolved their iMac or MBP connectivity situations.

    Hope this helps...

    .
     

Share This Page