iMac internet issues

Discussion in 'Mac Basics and Help' started by Alaskanmac, Mar 12, 2009.

  1. Alaskanmac macrumors member

    Joined:
    Aug 30, 2007
    #1
    My 20" 2007 iMac has been having some very slow internet recently and I cannot figure out why. We have one of the apple routers and the imac is using wireless internet.

    The most confusing thing is that my old 2004 toshiba laptop and my new 2008 macbook pro are both connecting to the internet very fast. Surfing the web is nearly 5 times faster on both of these then it is on my imac.

    Also I should note that often in the status bar it gets stuck on connecting. For example if I type www.google.com and hit enter, the status bar sits on "connecting to www.google.com"
     
  2. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #2
    1. Download OnyX (a free maintenance utility).
    http://www.macupdate.com/info.php/id/11582

    2. Open OnyX and Click Cancel on these two Alert Panels:
    -Cancel the S.M.A.R.T. Box
    -Cancel the Startup Volume Box

    3. Enter your Password

    4. Click on the Cleaning Tab

    5. In each tab, execute the command. Check all the boxes in each tab. When its finished in that tab, it will ask you to reboot. Say NO. Go on to the next tab and repeat until all tabs are done. THEN REBOOT.
     
  3. Alaskanmac thread starter macrumors member

    Joined:
    Aug 30, 2007
    #3
    Did this to no avail.. Still gets stuck on "contacting" for safari and "connecting to" on firefox... Someone please help me because my iMac is DRIVING ME CRAZY
     
  4. OneBlueFire macrumors member

    OneBlueFire

    Joined:
    Oct 12, 2008
    Location:
    Manila, Philippines
    #4
    Have you at least tried to restart your router or check if all the settings on it are correct (via Airport Utility)?

    The 2 machines that're using the same router, are they PHYSICALLY connected to the router or are the using Wi-Fi as well?

    From the looks of it, it seems that there's a setting on your router that needs to be corrected.

    1. Restart Router
    2. If that doesn't work, check Airport Utility and verify that all your settings are correct (such as Radio Mode, Channel, Wireless Security, Access settings, etc.) then restart the router.
    3. If that doesn't work, check the settings on your Mac. Sometimes Locations can have adverse effects on internet connections. Delete all Locations then create a fresh one. Make sure that all settings are correct. Automatic usually works best for the average user.
     
  5. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #5
    Try going into your system preferences under network. You should see a Location pull down menu. It should say Automatic if you have never changed it before, click it and then create a new location. Change any appropriate info you may need for your connection (most major ISPs are usable with the default settings) and then try your connection after that.
     

Share This Page