iMac keeps rejecting password

Discussion in 'Mac Basics and Help' started by will0407, Sep 18, 2014.

  1. will0407 macrumors 6502a

    Joined:
    May 20, 2006
    #1
    We have a late 2012 imac, which has been running fine since we bought it in Jan 2013.
    Last night, my Dad (the admin on the computer) tried to login in, and it kept rejecting his password. Caps lock wasn't on, and he tried several times with no luck. Logs into my Mum's account fine. For info, the dots appear when he types a letter so it's picking up the keystrokes.

    After sending him details on how to do the 'resetpassword' via terminal, he restarted it and it accepted his password without the need to do the resetpassword process. Thought it was just a blip.

    But...this morning, same thing happened, and he was unable to log in. Repaired disk permissions via Mum's account but still no joy. Left it, went to work, came back and logged in fine. Went for dinner, came back, locked out again.

    Does anyone know what would cause this and how to solve it? It's completetely out of the blue and has been running with no issues since Jan 2013!
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    Location:
    Sailing beyond the sunset
    #2
    Could be a malfunctioning keyboard. The simplest way to find that out is to swap with a different keyboard.

    Or if the current keyboard is Bluetooth, it could be dying batteries, or batteries with poor electrical contact. Replace batteries and try again is a simple test of that.
     
  3. will0407, Sep 18, 2014
    Last edited: Sep 18, 2014

    will0407 thread starter macrumors 6502a

    Joined:
    May 20, 2006
    #3
    Tried with a usb keyboard, no joy.

    Did the resetpassword thing, and seemed to login ok.

    Just a bit baffled as to why it works and doesn't work with no consistency.
     

Share This Page