iMac keeps waking up

Discussion in 'iMac' started by atMac, Jun 26, 2011.

  1. atMac macrumors 6502

    Joined:
    Jun 20, 2011
    #1
    About every 15min my iMac will wake from sleep. I look in teh console and see this:
    6/27/11 12:24:13 AM kernel Wake reason = EHC2

    Which is my Bluetooth mouse and Keyboard being disconnected.

    In every case before it I have this line:
    6/27/11 12:24:13 AM airportd[208] process_dlil_event: Set power failed err = -3903 (Operation not supported)

    I have my wireless disabled though.

    Any ideas?
     
  2. lyrrad721 macrumors regular

    Joined:
    Jul 28, 2010
    #2
    Mine wakes from sleep but in Bootcamp, after 15min or so. I am running Windows 7. Hmmm :rolleyes:
     
  3. atMac thread starter macrumors 6502

    Joined:
    Jun 20, 2011
    #3
    It keeps saying its due to my BT controller.

    Maybe I need to reinstall OS X?
     
  4. atMac thread starter macrumors 6502

    Joined:
    Jun 20, 2011
    #4
    No ideas?

    Does anyone know where the Bluetooth preferences are located so I can try trashing them? If that doesn't work I may have to try a reinstall, which would suck as I just got everything setup.
     
  5. atMac thread starter macrumors 6502

    Joined:
    Jun 20, 2011
    #6
    The 1st link only talks about 3rd party mice, not Apple branded Keyboards or Mice, and the 2nd doesn't really help as I've already determined that it's my bluetooth keyboard and mouse disconnecting thats waking up my iMac based on my Console, or the iMac disconnecting from the keyboard/mouse.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    /Library/Preferences/com.apple.Bluetooth.plist
     
  7. mrfoof82 macrumors 6502a

    Joined:
    May 26, 2010
    Location:
    Lawton, OK
  8. atMac, Jun 27, 2011
    Last edited by a moderator: Jun 27, 2011

    atMac thread starter macrumors 6502

    Joined:
    Jun 20, 2011
    #9
    Thank you, I'll try deleting it when I get home.

    Funny is always appreciated. haha
     
  9. atMac thread starter macrumors 6502

    Joined:
    Jun 20, 2011
    #10
    It seems deleting the Pref fixed it. Thanks guys.
     
  10. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    Glad you got it sorted!
     
  11. yashrg macrumors regular

    yashrg

    Joined:
    Feb 21, 2008
    #12
    Thank you. Just deleted my bluetooth preferences. Lets hope the iMac doesn't wake me up tonight!
     

Share This Page