iMac language issue

Discussion in 'iMac' started by markoid63, May 21, 2013.

  1. markoid63 macrumors newbie

    Joined:
    May 21, 2013
    #1
    Any help or advice -
    I bought a second hand iMac 20" Core 2 Duo in great condition. It had Snow Leopard installed with an asian second language below english in menus and log ins etc. I decided to install Mountain Lion as a fresh install not an upgrade but ran into a slight problem. Everything was in some asian language that I could not read, but I somehow managed to fudge my way through what looked like the right prompts and got it installed. I then somehow worked my way through changing the language to English and all seems okay. What concerns me is, I had to check something out by starting in safe mode and all the wording etc was in asian language again. I logged in, and all is in english. I'm worried that if I want to reinstall, I'm going to have to fudge my way through again which I don't want to do. Is there something I can do to make this obvious built in language english?
    Any help would be appreciated.
     
  2. eattherich macrumors 6502

    eattherich

    Joined:
    Jul 8, 2011
    Location:
    Berlin
    #2
    I'm not sure exactly what's going on in your situation but I know that you can run "sudo languagesetup" in Terminal to change the system language. Be careful using sudo in Terminal, however, if you're unsure of what you're doing. That said, that command will ask you to choose a language for your system - it's pretty easy.
     
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    Open Language & Text, click the Edit button and untick all boxes except English, that should do the trick.
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    You don't need terminal to do this....justperry's tip should work...OP:...is the copy of OSX registered to YOUR account?
     
  5. eattherich macrumors 6502

    eattherich

    Joined:
    Jul 8, 2011
    Location:
    Berlin
    #5
    Yeah, I know what you're saying but I once tried this here in Germany and despite changing everything to English, the login screen was still in German. The terminal route was the only way to completely change everything on that system.
     

Share This Page