imac late 2008 20" + SSD Samsung 850 EVO issues on install

Discussion in 'iMac' started by xphere, Dec 3, 2015.

  1. xphere macrumors newbie

    xphere

    Joined:
    Jun 7, 2008
    #1
    Hi all,

    I've recently installed a Samsung 850 EVO SSD drive (500gb) on an iMac late 2008 20", following ifixit guide. All steps have been followed carefully, sensor temp cables are OK, etc...

    After all the hardware part was done, I boot the mac, and I proceed to install a fresh "El Capitan" install, from a 16Gb pen drive (previously prepared with Disk Maker X). Before installing, I delete the SSD partition and make a new one (Mac OS Journaled), with no issues. Even I did a verification, and the disk seems OK.
    The installation takes a LOT, specially on the last second (i stays like +15minutes on "one second remaining").
    After waiting a lot, the installation seems to finish, but after booting seems that the system is not recognized, because it boots again the installation from the pen drive... I've tried booting with "alt" pressed, but the SSD does not appear as a valid boot device, eventhough, when I do the install process, the SSD drive appears as a valid internal drive for installing the system... ¿?

    Do you have any idea of what's happening?

    Thanks in advance!!
     
  2. Boost3devo macrumors newbie

    Joined:
    Nov 6, 2015
    #2
    I don't know if its the same case and a problem with the firmware, I installed on a work mid 2010 27' imac a ssd to boot windows. I leave mac os on the oem 1tb hdd. I recheck the ssd connections a few times and the imac NEVER recognized the SSD from cold boot. The only way the imac found the ssd (windows) is when its been on around 10 to 15 mins. What I did is that I put the machine to turn on automatically everyday half hour before I start using it.
     
  3. davegoody macrumors 6502

    davegoody

    Joined:
    Apr 9, 2003
    Location:
    Reading, Berkshire, England
    #3
    Check to make sure that you have set the disk not only to Journalled, but also have set the partition to GUID if not it won't boot.
     
  4. xphere thread starter macrumors newbie

    xphere

    Joined:
    Jun 7, 2008
    #4
    Yes, the partition was set to GUID.

    Yesterday I gave it a new try and installed all again, and waited for many (many! time)... and seems that now it works! all the installation finished ok, and now boots from the SSD.... its strange, but seems that it works... :S
     

Share This Page