iMac losing internet connection while downloading

Discussion in 'iMac' started by Steve-Jobs, Jul 7, 2014.

  1. Steve-Jobs macrumors 6502

    Steve-Jobs

    Joined:
    Oct 18, 2010
    #1
    Hi all, in the last few weeks I keep getting internet connection error while downloading a movie or a big file. I used to leave the computer to it, come back few hours and it was downloaded and ready to go. Now I keep getting network error in the middle of the download.
    I have no other issues with normal use. We also use the wi-fi for our tablets and phones. Can anyone suggest anything I'm running the latest OS on a 2010 iMac

    Cheers
     
  2. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Try reset the router and cable modem. If may not be the Mac's problem.
     
  3. Steve-Jobs, Jul 8, 2014
    Last edited: Jul 8, 2014

    Steve-Jobs thread starter macrumors 6502

    Steve-Jobs

    Joined:
    Oct 18, 2010
    #3
    Thanks for the reply. will try it tonite. If the problme is with the computer do I need to reset the SMC settings? will that help? what I don't understand is why it's not getting any network error while in normal use?

    EDIT: what if I reset the PRAM settings and delete system configuration as well?
     
  4. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    If you suspect there is something wrong about the computer, you can always do the followings in order.

    1) Reset SMC
    2) Reset PRAM
    3) Boot into recovery partition
    4) Repair disk
    5) Repair permission (run this at least twice until there is no fault message)
     
  5. Steve-Jobs thread starter macrumors 6502

    Steve-Jobs

    Joined:
    Oct 18, 2010
    #5
    Thanks for that. Apple must have heard me. when I got home there's was a software update specifically for this issue. Everything looks normal. I downloaded a movie without any problems..

    Cheers
     

Share This Page