iMac Magic Trackpad Scrolling Stuttering / Lag / Jumpy

Discussion in 'iMac' started by JavierDiaz4, Dec 10, 2014.

  1. JavierDiaz4, Dec 10, 2014
    Last edited: Dec 10, 2014

    JavierDiaz4 macrumors member

    Joined:
    Sep 12, 2007
    #1
    Is anyone else having this issue with their Magic Trackpad on Yosemeti, specifically on their IMacs? I can't say its the trackpad, because I've tried the magic trackpad on my Macbook and my wife's Macbook Pro and it does not exhibit the same problem.

    The problem at hand is that when moving the pointer around it lags so much it exhibit a jumpy behaviour as it tries to catch up and most of the times it skips so much it jumps form one side of the screen to ther other. Any ideas? Again, I'm attributing this to my IMac on Yosemeti. I've tried PRAM reset and switching the batteries and also turning off Time Machine. Thanks.\

    I might even go as far as saying that the Keyboard is also lagging when typing. I've noticed a slight delay here too.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    How many Bluetooth devices are connected to your iMac?
     
  3. JavierDiaz4 thread starter macrumors member

    Joined:
    Sep 12, 2007
    #3
    Same as always, the Bluetooth Keyboard and the Bluetooth Magic Trackpad. Nothing has changed since I bought the computer 2 years ago, with the exception of the OS.
     
  4. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #4
    I find that cycling Bluetooth off and on usually fixes that.
     
  5. JavierDiaz4 thread starter macrumors member

    Joined:
    Sep 12, 2007
    #5
    I tried that, works for about 15-20 seconds. Issue comes right back. Again, I thought it was the bluetooth device, but as mentioned, I tried it on two macbooks and it didnt happen there. So I'm assuming my Mac's bluetooth is starting to fail or it's something buggy around the OS as some people had some issues with Yosemite earlier on with the OS messing with the Bluetooth.
     
  6. JavierDiaz4 thread starter macrumors member

    Joined:
    Sep 12, 2007
    #6
    Going to bump this up! I tried PRAM Reset 4 times over. Nada. Turned off bluetooth and turned it back on, Nada. Still not sure if I can attribute this to the IMAC or the Trackpad. Thinking of buying a new trackpad and if it relieves the issue then it'll be obvious, if its not, then I'll just return it and deal with still looking for the problem. But any insight you guys can provide will be appreciated.
     
  7. steve23094, Dec 13, 2014
    Last edited: Dec 13, 2014

    steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #7
    Any USB devices? Incorrectly shielded USB devices and cables put out a heck of a lot of interference in the 2.4Ghz band which is used by both WiFi and Bluetooth.

    Source: http://www.intel.com/content/dam/www/public/us/en/documents/white-papers/usb3-frequency-interference-paper.pdf

    Oh, and have you made sure your batteries are good?
     
  8. JavierDiaz4 thread starter macrumors member

    Joined:
    Sep 12, 2007
    #8
    No, no USB devices connected to it.

    In other news, I tried my wife's Magic Mouse and it works flawlessly. So I figured it can't be the Bluetooth and so I'm narrowing it down to the Magic Trackpad.

    Went and got another Trackpad and the skipping is occurring on this trackpad as well. I'm thinking its a trackpad exclusive issue around Yosemite. Definitely would be good to see if anyone eventually shows up with this issue as well.
     
  9. Mindinversion macrumors 6502

    Mindinversion

    Joined:
    Oct 9, 2008
    #9
    You're going to hate me for this, but I've actually had this issue. it turned out it was a conflict with something that was running in the background. . and for the LIFE OF ME I can't remember what the heck the software was that was causing it... I would go into activity monitor and sort by CPU %, see if anything is sucking up more than 20% CPU resources. If you find something, end the task and see if it resolves.

    I'm sorry I can't be more help, I resolved this awhile ago and have since moved from the old mac mini to a new RiMac.
     
  10. JavierDiaz4 thread starter macrumors member

    Joined:
    Sep 12, 2007
    #10
    Your statement made me think about my router. I have an airport station and I have it set to 2.4Ghz because of my Roku. I changed it to 5Ghz. That took the erratic behavior away from the trackpad. Insaneeeee. It's worked for years. I recently introduced a FireStick to the house and I'm assuming that, the Roku and the 2.4Ghz may have been creating interference with the bands. Right around the acquisition of the Amazon FireStick is when it all started. I'll have to upgrade my Roku now.

    Thanks for the tip.
     

Share This Page