iMac Mid 2007 - Very Slow

Discussion in 'iMac' started by Oliver G, Mar 25, 2010.

  1. Oliver G macrumors regular

    Joined:
    Sep 24, 2007
    Location:
    Melbourne, Australia
    #1
    I have a 20" iMac mid 2007 2.4Ghz, 320GB, 2Gb machine running Snow Leopard. Today I turned it on and it was running fine. But around three hours of using it suddenly froze. I had to force the turn off using the power button. When i turned it back on it took about 4 mins to get to the login screen.

    Once I logged in the spinning wheel came up and the only think that loaded was the Spotlight sign.

    This kept happening until about the third time of turning it off and on. When it finally completed login. But it is now extremely slow and it just about freezes when I open more than one application.

    Can someone please help me
     
  2. js81 macrumors 65816

    js81

    Joined:
    Dec 31, 2008
    Location:
    KY
    #2
    Repair permissions with Disk Utility. You could be having hard drive issues, but not sure... any strange sounds?

    Also, unplug any peripherals (printer, ext. hard drive, etc.) before you boot up and see if that helps.
     
  3. Oliver G thread starter macrumors regular

    Joined:
    Sep 24, 2007
    Location:
    Melbourne, Australia
  4. gber macrumors newbie

    Joined:
    Jun 18, 2009
    #4
    There is no risk to doing disk repair. I have the same imac model you have and experienced the same problem a few months ago. After doing disk repair , the problem went away.
     
  5. Oliver G thread starter macrumors regular

    Joined:
    Sep 24, 2007
    Location:
    Melbourne, Australia
    #5
    Ok. Thanks will try tomorrow. I didn't have any strange sounds though.
     

Share This Page