IMAC no powering up

Discussion in 'iMac' started by dannieboiz, Sep 6, 2016.

  1. dannieboiz macrumors newbie

    Joined:
    Sep 22, 2013
    #1
    I have a 2011 IMAC 27" with an i5 processor, I open it up to put in an i7 2600 after I put it all together it wouldn't power on. On the logic board, I can see 1 lights on. With the LCD removed, I can see the fans trying to kick in and shutting back down.

    Is there anything I can do like resetting the power supply or the machine?
     
  2. Tim in Scottsdale macrumors member

    Joined:
    Mar 13, 2016
    Location:
    Scottsdale Arizona
    #2
    Hello

    Check your connectors carefully, you may have plugged it back together wrong.
     
  3. dannieboiz thread starter macrumors newbie

    Joined:
    Sep 22, 2013
    #3
    thanks, stupid me I tried to power it up before dropping the RAM in. It's booting fine now. However I now have a new problem. my ODD and CPU fan is running @ max speed it seems. ODD @ 3500 and CPU @ about 3900 RPM. Tried resetting SMC and PRAM with no luck. Any suggestions?
     
  4. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #4
    Thermal paste on cpu not even or its sensor you may not have fully plugged in. I would also say the connection for the other sensor due to all the pull apart done.
     

Share This Page