iMac not connecting to existing home wireless internet

Discussion in 'Mac OS X Server, Xserve, and Networking' started by bodanzarama, Feb 6, 2010.

  1. bodanzarama macrumors newbie

    Feb 6, 2010
    Hello to anyone who might be able to help.

    We have a PC in the upstairs office with cable/DSL router for Internet (through Comcast). This service also has a wireless connection. We have a Macbook laptop which connects effortlessly to our home network and we use it all over the house. We simply clicked the internet symbol on the top right (looks like a little amphitheater), selected our network, entered the password and have been connected ever since.

    Today we brought home a new iMac and set it up in basement office. Tried the same routine. Clicked on the internet symbol, selected our network, noticed that the signal is just as strong as it is upstairs, typed in password but that's as far as we get.

    I've gone the rounds with the Assist and the Utility features. I've shut the Airport on and off. I've tried setting up a new network. I do notice that the iMac has a "self-assigned" ISP "and cannot connect to the Internet." Does this mean I can't ever connect? Do we need to replace the self-assigned ISP with our Comcast IP address?

    I've read here and there that our router might have Macs blocked and we could add this iMac as a secure system to get on the network. But we haven't played with the router's settings because we wouldn't know how. Besides, the Macbook connects fine.

    Does this have anything to do with TimeMachine? Do I need to get Airport Extreme? We really thought we could just jump onto the existing network. In fact, I'm typing this from the Macbook laptop while staring at the new iMac which won't connect.

    I'm overlooking something really basic, right? We're going in circles with the help available on the iMac.

    Any advice? Very much appreciated!
  2. calderone macrumors 68040


    Aug 28, 2009
    You will have to check the router and see how many IPs it can give out. You may have reached the maximum and you will just have to increase that range.

Share This Page