iMac not powering on

Discussion in 'iMac' started by Lilybee28, Mar 15, 2015.

  1. Lilybee28 macrumors newbie

    Joined:
    Mar 15, 2015
    #1
    Today I went to use my iMac purchased in 2008. I tried to power it on and it wouldn't turn on. I checked the power cord. Everything is fine with the outlet. I unplugged the power cord, unplugged the Ethernet, and tried to turn it on again. This time it started. I was flooded with relief. But after about two minutes it randomly shut down again and won't turn on. What could be causing this problem? It's been working fine until now and it definitely is not overheating... Could it be a power surge or something wrong with the socket or is my computer just dying?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Your power supply maybe starting to fail. Try leaving it unplugged for an extended period of time and try it again.
     
  3. Lilybee28 thread starter macrumors newbie

    Joined:
    Mar 15, 2015
    #3
    Okay. If I unplug it for five minutes or so it turns on for about 30 seconds. What does it mean that the power supply is starting to fail?
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    That does greatly suggest that the power supply is starting to fail.
     
  5. Lilybee28 thread starter macrumors newbie

    Joined:
    Mar 15, 2015
    #5
    Well at least I have a diagnosis ! Thanks :)
    Is there anything I can do to prevent this?
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    If you can get it to turn on, maybe never turn it off again. Other than that, replacing the power supply, if it is the cause, would correct the problem.
     
  7. Lilybee28 thread starter macrumors newbie

    Joined:
    Mar 15, 2015
    #7
    It won't stay on / it shuts down in a minute or two. Is this a problem of age? I am wondering if it is due to the poor wiring in the apartment I am subletting. There are several light fixtures that don't work and about three weeks ago the light fixture in the bathroom just died. When I first moved in I had a modem that suddenly died and all of the subsequent comcast equipment I rented has functioned poorly. The tv and Xbox have always worked fine though. Was there some surge or problem with the electrical outlet that made the PSU fail so suddenly or should
    I expect this with a seven year old unit?
     
  8. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #8
    I may be a problem with the wiring. It is an older machine, but they aren't really old enough to start having these problems unless defective or caused by external forces, such as bad wiring. If you can, try using it in another area outside of your apartment to see if it still has problems.
     

Share This Page