Imac not reading firewire 400

Discussion in 'iMac' started by tednunesrunning, May 25, 2008.

  1. tednunesrunning macrumors newbie

    Apr 29, 2008
    Well it just stopped working...but not all together. I have a new Imac 2.4gGhz I bought the day they were upgraded. I've recently purchased a Presonus Firestudio Project recording interface that requires firewire 400. I had it up and running and everything seemed to be going smooth. But when I came home from work today and started it up, it wouldn't sync with my Imac. I thought it was my Firestudio project so I tried different firewire cables and it didn't fix it.
    After that I tried hooking up my External Firewire 400 hard drive and now it's not reading that either!

    It's ALWAYS read the hard drive.
    I call apple care and they take me through a couple steps and when I restart my computer with the hard drive/firestudio audio interface the Imac recognizes it.

    But once I turn them off and turn them back on again, it wont recognize it.
    I'm "ejecting" the hard drive as well as the firestudio when I'm done using them.

    Anyone have any advice? Is there something "turned" off in my machine?
    Are there any preference settings I can adjust?
    Any help thanks...Ted
  2. MacHappytjg macrumors 65816

    Mar 24, 2008
    just tell apple about its an on going defect that wont help when ever they do the steps im sure they will understand it must not be getting power or somthing unusual for only one port to stop working
  3. tednunesrunning thread starter macrumors newbie

    Apr 29, 2008
    Thanks...I haven't tried the 800 port because I don't have anything that requires 800. I'll call apple tomorrow. I thought that's odd that it just stopped recognizing the input.
    So I take it there is nothing I can "switch" on and off to help remedy the situation? Thanks for the response Ted
  4. tednunesrunning thread starter macrumors newbie

    Apr 29, 2008
    Hey I just found that this isn't a new thing. There are a ton of intel imac users that have the firewire ports not reading the input.
  5. Cave Man macrumors 604

    Cave Man

    Try this:

    1. Connect a device to the FW port.
    2. Launch terminal and copy and paste the following:

    sudo kextload -b

    3. Press "return" and enter your password. Press "return" again.

    This should load the FW driver. If your device is now recognized, you know you have a software issue. If it isn't recognized, you may still have a software issue, but it could also be a hardware issue.
  6. tednunesrunning thread starter macrumors newbie

    Apr 29, 2008
    Thanks....still nothing.
    The thing is...If I have the device turned on...hooked up to the Imac, and then RESTART the imac...then the imac will recognize it.
    But if the imac is on and I plug in the device, recording interface/external hard drive, and then turn on the device then it wont recognize it.
    It still doesn't work.

    Why would it stop working all of a sudden? Thanks for the responses...Ted

    I shouldn't have to restart my computer every time I want to use the firewire ports.
  7. Cave Man macrumors 604

    Cave Man

    Well, then it's unlikely you have a hardware issue. Try the sudo command and see if it works. Sometimes kexts get corrupted.
  8. tednunesrunning thread starter macrumors newbie

    Apr 29, 2008
    Sudo command?...Is that what you had me do...or something different? I'm really not very computer savy...can you walk me through some steps? thanks Ted
  9. Cave Man macrumors 604

    Cave Man

    Go to the folder Applications/Utilities. There is an app there called Terminal. Launch it. Copy this entire line:

    sudo kextload -b

    Switch over to your terminal app and paste this line into it. Then hit return. Sudo requires you enter your password the first time you invoke it from each terminal session. Type in your login password (no characters appear, but it is receiving it) then press "return" again. This line does a force load of the Firewire drivers kext ("kernel extension"). If after invoking this command and you do not get FW working, then there is another software issue or, less likely, a hardware issue. For whatever reason, your kernel is losing its ability to communicate with your fw ports.

    If it does work, then you should only have to type it once per boot (unless kernel continues to have problems).
  10. tednunesrunning thread starter macrumors newbie

    Apr 29, 2008
    Ok, I got you.
    I did it and after I plugged my firewire cable from my device to the Imac and it still doesn't recognize it.
    Is there anything else I could try? thanks Ted
  11. Cave Man macrumors 604

    Cave Man

    Other than a fresh install of the OS, I don't know what else you could try. If a reinstall still has the problem, then I suspect you have a hardware issue. I think you ought to have Apple take a look at it.
  12. tednunesrunning thread starter macrumors newbie

    Apr 29, 2008
    Thanks for your time. I've had this Imac since the April update. 28th? i think? so It hasn't even been a month. I guess I'll have to take it into apple. I just don't want to be out of a computer when everything else works fine.
    I've read comments of other people who had the same problem, end up getting a NEW IMAC, and then STILL have the same problems. I'm not sure.

Share This Page