Imac not sleep since lion

Discussion in 'Mac OS X Lion (10.7)' started by Sapphire08, Jul 27, 2011.

  1. Sapphire08 macrumors member

    Sapphire08

    Joined:
    Dec 20, 2008
    Location:
    England UK
    #1
    I can't believe the problems that Lion is causing everybody - we or should I say I didn't have any problems when I went to Snow Leopard.

    My iMac (early 2008) with second monitor and external HD for time machine won't sleep at all.

    I usually schedule mine to go sleep at 2am - it ignores the scheduling?
    If I manually (apple>sleep) the screen goes sleep but not the machine?

    Normally I don't have to do anything and it sleeps soundly and my external HD stops warring, light goes out and peace in the room but since lion the iMac won't sleep and the external will not stop warring / keeps its lights on :eek:

    I have tried normally with all my apps open - no good!
    I have tried switching all apps off (fast switch>Cmd+q) so only finder shows and then Apple > sleep but only the display goes sleep !!!
    I do not have internet sharing ticked.

    What can I do - have I got to Shut Down every night now??? I thought sleeping was the best thing for it - it's slept everynight since new and I love it to bits but was is going on????

    NB My Macbook Pro - will still go to sleep manually.
     
  2. Sapphire08 thread starter macrumors member

    Sapphire08

    Joined:
    Dec 20, 2008
    Location:
    England UK
    #2
    Ok well I solved the problem but unticking file sharing, printer sharing and scanner sharing which I had ticked - ad my iMac went sleep at at last!

    I ticked each one and tried to sleep after each tick to see if I could find the culprit but after each one it still sleeps so now they are all ticked again I have windows open i.e. mail safari like i would normally and it still sleeps - hooray!!

    So I am happy although I don't actually know what the problem was - I suspect file sharing i.e. acting like a server but in leopard it always went sleep anyway so we will see.

    I may have to move my shared files to the macbook pro it if happens again. I have wondered about trying the apple server on the macbook pro but I have never used / created my own server before???
     
  3. Tygernoot macrumors member

    Joined:
    Jul 3, 2003
    Location:
    London
    #3
    I switched off Internet Sharing and it went to sleep. Still have file sharing (and one other thing I think) enabled but that doesn't prevent if from going to sleep.
     
  4. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #4
    Yep, Internet Sharing, just had this problem myself, and thanks to you guys, fixed it :) Cheers
     
  5. blackomega31 macrumors member

    blackomega31

    Joined:
    Aug 6, 2011
    #5
    Well here is the ugly truth. I just called apple on this. I had no idea how far they wanted to take this make the computer like an iPad idea. But here it is. Apple has re tasked system sleep to be of you plan on stepping away for less then an hour then use sleep but any longer then that they recomend shutting it off. I guess they were so convinced that system auto restore was the second comming or something. Why should I have to turn off file sharing just to get my Mac to sleep. And on that note, why should I have to wait for my computer to boot up and wait for all my apps to resume. I'm starting to wonder if they have chimps on typewrighrers just pounding away hoping that in all the chaos something good would come out. And the result was lion. The worlds first operating system that made the mass want to Downgrade to 10.6 just to get an upgrade
     
  6. Sapphire08 thread starter macrumors member

    Sapphire08

    Joined:
    Dec 20, 2008
    Location:
    England UK
    #6
    Well its definitely 'file sharing' that causes it on mine, but only if someone has actually access a shared file. ie if over 2-3 days no one shares a file it sleeps fine, but soon as somebody access a file then it seems like it opens a connection to that machine and wont close it down to sleep unless you actually untick file sharing and then confirm disconnect of that sharing user.

    Just thought it might help others

    I feel this should be made a switchable option - ie stay awake when others sharing or allow the sleep to overide and cut the connection! Come on Apple!
     

Share This Page