iMac not sleeping and screensavers not activating

Discussion in 'iMac' started by ryan.stewie, May 1, 2009.

  1. ryan.stewie macrumors regular

    ryan.stewie

    Joined:
    Jan 15, 2008
    Location:
    Australia
    #1
    All of a sudden my iMac has just started not sleeping after the time its supposed to and the screensaver wont turn on when its supposed to. I havent installed any new software, its just happened out of the blue, I can still use hot corners to activate sleep and the screensaver but id rather have them activate by themselves. But they're not, and all of my System Preference's sleep and screensaver options are fine. Why wont my Mac sleep and/or turn on the screensaver after set times?
     
  2. RonelEllis macrumors newbie

    Joined:
    Feb 28, 2009
    Location:
    Wellington, New Zealand
    #2
    re: iMac not sleeping and screensavers not activating

    Ryan, thank you for posting this one. This is exactly what is happening with my iMac. Do you think it could be caused by an recent operating system software update perhaps?
     
  3. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #3
    Have you tried rebooting? That solved my problem. Sometimes it just doesn't want to sleep :D
     
  4. RonelEllis macrumors newbie

    Joined:
    Feb 28, 2009
    Location:
    Wellington, New Zealand
  5. adammelancon macrumors member

    Joined:
    Mar 5, 2009
    #5
    Same here, reboot fixes it, but only for a little while, then the screensaver/screen-sleeping won't kick in.

    If i kick in the screensaver with the hot corner it will work, but I have screen sleeping set for another corner, when I activate it, it sleeps the display only for about 4 seconds, then it pops back to the desktop.

    24" April 2008 2.8Ghz iMac 4GB RAM running 10.5.7

    List of apps I use daily:
    Firefox
    iTunes
    Skype (stays connected)
    Drobo Dashboard (stays running)

    I've heard sometimes your sharing preferences can cause this...
    Sharing boxes I have checked in System Preferences:
    Screen/File/Printer sharing enabled
    remote login enabled
     
  6. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #6
    Firefox is known for not letting your Mac sleep. I have the same problem when using Firefox3.5b4(which is my browser of choice these days) - I saw a glimpse of improvement while using nightly builds of Firefox but I'm not sure if it was pure luck or that they have actually improved Firefox in this regard.

    My screensaver kicks in fine but the system won't sleep correctly on time out set in System Preferences.

    Resetting the SMC & PRAM does not help either. It is simply Firefox if you are using this browser. Or it's some sharing activity keeping the system alive.
     
  7. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #7
    I agree with the above post that FF3 is the culprit. Take a look at this thread, in particular post #4.

    Not a solution, but PleaseSleep is a work-around that I use.
     
  8. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #8
    ^^One thing I noticed last night that didn't occur to me before was to close all Firefox 3 windows; leaving neither browser or minimized windows open- and then the system slept. This is the easiest solution. It's often luck however if my system sleeps correctly.

    Edit... while it seems stupid to leave Firefox 3 open instead of quitting it - that's just what I did
     
  9. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #9
    This also came up in a thread a few months ago. The conclusion was that if anything is running in the background, it could prevent sleep. Backup, maintenance, video transfer, and the like.
     

Share This Page