iMac OS10 and Ipod touch

Discussion in 'iMac' started by Moped150, Mar 30, 2011.

  1. Moped150 macrumors newbie

    Joined:
    Mar 30, 2011
    Location:
    San Diego, CA
    #1
    Returned an iPod Touch because it was not compatible with my iMac OS10 (10.4.11). Essentially, I was told by the 12yo at the genius counter that it is too old or I suspect he meant I was too old. Anyway, humiliate me here and tell me simply what is the issue. And, would it apply to an iPhone?
     
  2. rnb2 macrumors regular

    Joined:
    Jan 23, 2006
    Location:
    West Haven, CT, USA
    #2
    Looks like you'll need OS X 10.5.8 for either a Touch or iPhone. What Mac do you have, and how old is it?
     
  3. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #3
    You will in fact need 10.5.8 or higher to run the latest version of iTunes which is compatible with the latest generation iPods/Phones/Pads (think I covered the bases there). It's a dumb requirement, but that is nonetheless the issue.
     

Share This Page