iMac Pro < TB3 < 2017 MacBook Pro

rawweb

macrumors 6502a
Original poster
Aug 7, 2015
867
583
Trying to connect my iMac Pro to my 2017 MacBook Pro to create an After Effects render farm with Render Garden. However, when connecting the thunderbolt cable and connecting to the shared iMac Pro hard drive, I'm only getting about 450 MB/s write via Disk Speed Test to that shared drive. The iMac Pro reports around 2800+ MB/s. This seems ubsurd knowing the speed potential of Thunderbolt and why I can't get closer to what I would expect to see.

I tried various cables, even a thunderbolt 2 cable with the apple dongles on either end. I am baffled. Anyone got any ideas?
 

rawweb

macrumors 6502a
Original poster
Aug 7, 2015
867
583
Yes, thunderbolt bridge is active and working. Turned off all other networking protocols as well.

Also tried a speed test with target disk mode and the result was even slower. In the 200MB/s range. o_O
 

SecuritySteve

macrumors 6502a
Jul 6, 2017
743
858
California
You wouldn't happen to be using the charging cable from the MacBook Pro that happens to be Thunderbolt, would you?

I've noticed that cable sucks for anything other than charging.
 

rawweb

macrumors 6502a
Original poster
Aug 7, 2015
867
583
You wouldn't happen to be using the charging cable from the MacBook Pro that happens to be Thunderbolt, would you?

I've noticed that cable sucks for anything other than charging.
No, I have a OWC thunderbolt 3 cable, but I've also tried a thunderbolt 2 cable with adapters...
 

xgman

macrumors 601
Aug 6, 2007
4,777
606
Apple TB2 adapters have issues with the imac pro and TB2 chip. Best to avoid.
 

Zdigital2015

macrumors 68000
Jul 14, 2015
1,680
1,732
East Coast, United States