iMac Screen Stuck On Spinning Wheel??

Discussion in 'iMac' started by SpartakChempion, Nov 13, 2010.

  1. SpartakChempion macrumors newbie

    Joined:
    Nov 13, 2010
    #1
    I was away at a friend's yesterday and left my computer on and downloading a torrent (I have done this before and everything has been fine). When I came back today, I noticed that my computer was working very slowly so I restarted it. However, it would just stay at the grey screen with the wheel spinning forever instead of moving on to the blue screen.

    I know that this has been reported many times before, even on this forum, but everything I tried does not work. I tried:

    Holding down Command+S at startup and entering the command fsck -fy. Did not fix the problem
    Opening the Install Disc and going into Disk Utility. I repaired the permissions and verified that the HD has no problems but the problem persisted.
    Going into Safe Mode. This actually works fine, but unfortunately offers an extremely limited functionality of my computer.

    I also tried going into verbose mode. This was the last line of text:

    Executing fsck_hfs (version diskdev_cmds-491 .2¬2)

    It stayed like this for about 5 mins, then I got:

    AppleAHCIDiskQueueMAnager : : serPowerState(0x4645700, 2 -> 1) timed out after 100235 ms
    disk0s2: I/O error.
    0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [IOType Read] [PBlknum 404489864] [LBlkNum 1] [FDLogMsgID 2011335813] [FSLogMsgOrder First]
    0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevNode /dev/disk0s2] [MountPt /] [Path /private/var/db/BootCache.playlist] [FSLogMsg ID 2011335813] [FSLogMsgOrder Last]
    BootCacheControl: could not read playlist data

    Then nothing else appeared. I am using an iMac with 10.6.4. Please, can you give me help on how I can fix this problem? I hope the information helps. Many Thanks!
     

Share This Page