iMac - shut off screen?

Discussion in 'iMac' started by excommie, Nov 17, 2009.

  1. excommie macrumors regular

    May 12, 2009
    I know this has been discussed before, but I cannot stand that there is no option to shut off the screen. I know the Shift-ctrl-eject (not sure if I got this right, I'm at work now) works to turn off the screen, but I'm facing another issue.
    At night, I frequently record shows on Eye-TV and export them to iPhone, so I can watch them during the morning commute. When the show begins, iMac's screen wakes up. When the export to iTunes begins, the screen wakes up. I tried few utilities where the brightness dims 100%, but it's not the same as turning it completely off.

    Has anyone found a solution where you can turn off the display completely? Since my iMac is in my bedroom, this is a huge problem for me. I miss my Mac Mini....
  2. pyrosas macrumors newbie

    Nov 10, 2009
    There is an option in the hot corner setup (Expose & Spaces) where you can choose "Put Display to Sleep" as one of the hot corner setting. I can't exactly remember what's the key command for that right now.
  3. J the Ninja macrumors 68000

    Jul 14, 2008
    That won't do anything the shift+cntrl+eject shortcut won't do.
  4. Alan64 macrumors member

    Nov 4, 2009
    You can leave your mouse pointer in the corner overnight, but you don't want to stand there by the keyboard all night to re-press shift+cntrl+eject if/when the machine wakes up.
  5. rgarjr macrumors 603


    Apr 2, 2009
    Southern California
  6. harperjones99 macrumors 6502

    Nov 3, 2009
    Pressing 3 different keys is a "shortcut"? Heh I am out of touch ;)
  7. excommie thread starter macrumors regular

    May 12, 2009
    I don't think this will work. When the screen wakes up and the mouse is in the corner, you have to move it out of the corner and then move the mouse back to the same corner to turn off the display. At least that's the way it was under Leopard, haven't tried it on SL yet.

    In any case, it appears that there is no real solution.
  8. antmo macrumors member

    Feb 20, 2008
    try locking the screen...

    it may wake up the screen when those processes start, but it should quickly turn back off. when my screen is locked i'm pretty sure it turns off the backlight, unless i press a key or move the mouse, showing the login dialog. if i don't press a key or move the mouse for about 30 seconds after it shows up, it turns back off.

    i also have screensaver set to never start.

    if you open keychain and go into settings/preferences, check the "show keychain in menu" and a little lock will show up in the menu bar. then you can click on it and choose "lock screen" whenever you need to.

    not sure if this will solve your problem, but thought it might be worth a try.
  9. excommie thread starter macrumors regular

    May 12, 2009
    Thanks for the suggestion, but when the log-in dialog box comes up after locking the screen, backlight is on and stays on for a while. I cannot believe that after so many years Apple doesn't think that shutting the screen off (and keeping it off) is a useful feature that should be easily addressed with a software.

Share This Page