iMac snow and OS 10.3

Discussion in 'Mac Pro' started by m830mr, Jun 22, 2006.

  1. m830mr macrumors newbie

    Jun 22, 2006
    So I have a snow imac that had 9.1 and I decided to put os x 10.3 on it. After updating the firmware (4.1.9) I got started installing 10.3.3 from some emac restore DVDs. Once the installer is halfway through base system part 2 it gives the same error in the installer log each time.

    Error: Could not read archive file. -pax: End of archive volume 1 reached-

    Error: Could not write file. -pax:WARNING! These patterns were not matched:-

    Some files for Essentials may not have been written correctly.

    Install Failed

    Error detected
    Name: NSGenericException
    Reason: Some files for Essentials may not have been written correctly (code 1)
    root: Installer[108] Exception raised during posting of notification. Ignored. exception: Some files for Essentials may not have been written correctly (code 1)

    The installer then says you must restart. This happens at the same part each time. Now to me this says, "I can't read these files and cannot continue" The hd checked fine so to me I thought the DVD was bad. So now I tried to throw 10.2 on it from an older powerbook system restore dvd. Low and behold I get the same problem, the difference is though that it dosen't stop the installation on 10.2. It just keeps going and says the software was installed successfully, then when you try to run os x it won't boot and gives you a screen asking you to restart each time.

    So does anyone here have any suggestions? It's a 500mhz snow imac with 256mb of ram and a 26gb hd. I did run disk utility the hd checked out fine. I also selected it to format the hd when I first did the install wiping out os 9 so now I can't boot into anything.
  2. AlBDamned macrumors 68030


    Mar 14, 2005
    Therein lies your problem I expect. All eMacs are G4 processors. I would imagine the restored discs for these don't have a universal installer on them. Often (but not always) with similar processor machines, i.e. G4 PowerBook to G4 iBook, the discs will work. But it's highly unlikely these G4 discs will work on a G3 iMac.

    Your best bet if you really want to do this is find a cheap "Full retail" copy of Panther on eBay or similar. A guesstimate for the cost would be about $30-50.

    I don't think you'll find any genuine "G3 iMac" Panther discs because the G3 line was discontinued before Panther came out.
  3. m830mr thread starter macrumors newbie

    Jun 22, 2006
    ONe might think but

    the system met all system requirements for 10.2 and 10.3 respectively according to the os x installer. It didn't say anything about being G4 or emac specific. ONe would think that the installer would say so if it was specific to a certian mac model or cpu.
  4. eRondeau macrumors 6502a


    Mar 3, 2004
    Canada's South Coast
    Yup, you need a store-bought copy of Panther as only it contains all the config files for all possible installations. One originally sold for an eMac won't run on anything else. BTW, I have done exactly what you're doing -- about six months ago, on a 1999 iMac DVD / 400MHz / 13GB. It's now running 10.3.9 and it works great. As for your unable-to-boot problem, that's a little bit beyond my level of knowledge but I'm sure somebody else will take you through it.
  5. AlBDamned macrumors 68030


    Mar 14, 2005
    The computer probably wouldn't say that to be honest. I tried this ages ago with a G3 iMac and it got to a certain point - the grey apple screen - and just froze.

    I'm 99% sure it's the discs. Your actual G3 is more than capable of running 10.3 and 10.4 but it will not install it using those discs.

    Edit: Same thing with the PowerBook restore discs.

    Have you got the original discs that came with the iMac?
  6. m830mr thread starter macrumors newbie

    Jun 22, 2006
    No on the original installation disks

    All I had was the unit. It ran 9.1 flawlessly with no problems period. I got the 10.3 disks from Other World Computing, who advertised genuine 10.3 universal instllation disks. I got the emac restore dvd's, same product number so there was no inventory mix-uip.
  7. AlBDamned macrumors 68030


    Mar 14, 2005
    Well they're really not universal. I would hazard a guess that they might work on certain laptops and other G4 models, but the description of "universal" is wrong if they have "emac restore..." or similar on them.

    Get in touch with them and explain.
  8. m830mr thread starter macrumors newbie

    Jun 22, 2006
    Well I fixed the problem

    I confirmed with apple by part number that they were universal. Then I decided to do what I would do with a PC, strip it down to it's stock parts and try again. So I removed an extra 128mb card I had installed when I was running os 9 (it ran perfectly fine with this memory stick in it) and os x installed flawlessly from the emac restore dvds. I then popped the stick back in and now it's running perfectly with 256mb.
  9. Maxwell Smart macrumors 6502a

    Maxwell Smart

    Jan 29, 2006
    Sounds good, you might also want to think about running Tiger on that machine as it would probably run a bit faster. Glad to hear your problems were fixed.

Share This Page