iMac speakers sound quality in Windows

Discussion in 'Windows, Linux & Others on the Mac' started by mattsfk, Sep 25, 2006.

  1. mattsfk macrumors newbie

    Sep 25, 2006
    Hey everyone, I have a brand new C2D 17 inch iMac, and so far I've installed Windows and everything seems to be running as it should, and I absolutely adore my Mac.

    There's one gripe I have though. I can hear a notable difference in sound quality when it comes to playing music (and sounds in general) through the iMac's internal speakers in Windows. On Mac OS X it sounds great, while it's quite poor in XP.

    Has anyone else noticed this, and is there any possible way in which I could replicate the sort of quality of sound I hear on Mac OS X?

    Your help would be greatly appreciated.

  2. hide. macrumors newbie

    Nov 6, 2007
    Same problem with my iMac 24´´ buyed 2 month ago.
  3. nigrunze macrumors regular

    Jul 28, 2007
    Montreal, Quebec, Canada
    I know what you mean. The weird whooshing sounds and the static noises. Yuck.

    On my Aluminum 20" I downloaded the Realtek drivers and then the quality was MUCH better.

    Check the Device Manager to see what your sound card is. It's probably either a Sigmatel or Realtek card.
  4. TESEV macrumors member


    Jun 1, 2006
    New Orleans, LA
  5. PellePirat macrumors member

    Oct 23, 2007
    I got the same issue.

    Im pretty sure its a very crappy EQ setting that is build in the standard drivers. The effects just destroys all sound.

    Im dowloading the Realtek drivers that TESEV linked and hoping for the best. Ill post result laters.

    UPDATE: Well, installed new drivers, but no change really. The sound quality is still very horrible in XP via bootcamp.

    To explain the sound: Sounds like everything is recorded in low quality (to low hertz), like through a telephone. Midrange is way to high. Everything sounds wrong. If i turn on EQ ROCK mode, its a bit better, but nothing compared to when in OSX.

    Would love to be able to pass through that crappy cheap realtek effect processing software.
  6. NCRAW macrumors newbie

    Nov 17, 2007
    Exactly the same issue. After installing the 1.82 update, the wooshing was gone but quality is still terrible!! its a very simple fix Realtek, come on!!! doesnt take much, just freakin use no effects!!!
  7. NCRAW macrumors newbie

    Nov 17, 2007
    V1.84 of the driver is out now!!! lets hope it will be a nice xmas present (released on xmas day)

    god please let it fix the crappy quality!!
  8. NCRAW macrumors newbie

    Nov 17, 2007
    No, No , Noooooooooooooooooooo!!!

    The stupid new driver did diddly crappin squat!!

    What are they releasing it for, thanks for nothing. I read the updates, nothing important. just delete the godammm equalisers. :mad:
  9. joemama2413 macrumors member

    Nov 4, 2007
    does anyone know whats up with the volume level in windows, i put it on the lowest level when i play games, yet the volume is like halfway when im on mac
  10. NCRAW macrumors newbie

    Nov 17, 2007
    Separate os'es, hence separate sound control. u have to drop the sound on each operating system, thats why u would have noticed that ur "boooong" at the begining is loud.
  11. kwfl macrumors 6502

    Aug 20, 2007
    thanks, it is very clear and good qulaity now
  12. GavinTing macrumors 6502


    Sep 4, 2007
    Have you tried adjusting the Bass?

    Ah, I belive this is because the volume buttons on the mac actually adjust the software side of it.

    For eg, on a regular windows PC with external speakers, you would turn the knob on the speakers, that would be the hardware adjustment.

    The software adjustment would be to go to your taskbar and right click the sound menu, and adjust it down. The software side.
  13. gyohng, Nov 8, 2009
    Last edited: Feb 18, 2011

    gyohng macrumors newbie

    Nov 8, 2009


    I think the problem happens because OSX has some correction for the sound, and Windows doesn't have any processing.

    I have measured 24" iMac response and created a DSP code for Vista/Windows7 to apply this correction, and a beta version is ready. The solution doesn't work on Windows XP however.

    Here is a link:

    I also noted, that the microphone is switched on by default, which creates an unnecessary feedback in the sound.

    Please check the web page the instruction how to switch the microphone feedback off.

    The measurements were taken from my 24 inch iMac, so I cannot say for sure, how this algorithm will perform on a computer, which is acoustically different from 24 inch aluminium iMacs.


Share This Page