iMac stopped reading my external hard-drive

Discussion in 'Mac Basics and Help' started by swapzr, Oct 27, 2012.

  1. swapzr macrumors newbie

    Joined:
    Oct 27, 2012
    #1
    One day I turned on my iMac with my 1TB WD Ext HDD (WD Elements Desktop) connected and a small window popped up saying (The disk inserted was not readable by this computer) with the options of (Ingore and Eject). :confused: Before that, my HDD worked perfectly well and I used it almost daily. I looked into my Disk Utility and saw the HDD was being read, but on the title it says (2.2 TB WD EXT HDD 1021 Media). When I select it, it doesn't let me verify, repair, erase, partition, RAID, or restore it. BTW I'm running a 20-Inch iMac late 2006 model. I don't know whats wrong with it and I have valuable stuff in there. Is there any way I can save all of those files or is there any way of fixing this issue?
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Don't panic just yet. There are ways to get at and to save the data on the drive.

    Before you do anything else, you might try taking the problem drive to another Mac, and see what happens. DO NOT initialize it, just see if it mounts.

    DATA RECOVERY WILL PROBABLY COST YOU MONEY (shouting intentional). How much money depends on which approach you take.

    First, if you open System Profiler, what does it show when you check the "USB"? Does it show that the drive is connected? (I'll guess that it does, if DU sees it even with unreadable partitions).

    There are data recovery apps you can investigate, such as
    - DataRescue 3
    - Stellar Phoenix Data Recovery
    - Disk Drill
    - Nice 2 Recover

    I suggest you download one or more of them, and see what they do for you.

    HOW THESE APPS WORK:
    - You download the app for free
    - You run it on the problem drive
    - If the recovery app can access the problem drive, it will usually present a list of recoverable files, but you can only recover ONE file
    - You then pay the registration fee, get a code, register the app, and it "goes to work" on your bad drive.

    You WILL need a SECOND drive to serve as "scratch storage space" for the recovered files (as I said, data recovery costs money).

    I -suggest- you get one of these to use for your scratch drive:
    http://www.amazon.com/s/ref=nb_sb_noss?url=search-alias=aps&field-keywords=usb+sata+dock&x=0&y=0
    (many items shown, they all work the same, just pick one you like that's cheap)

    You will also need to obtain a "bare" SATA drive to go in the dock.

    Put the bare drive in the dock, connect it, initialize it (with Disk Utility), and it's ready to serve as the scratch drive.

    HOWEVER -- there is the possibility that the data recovery software won't be able to "see" the problem drive, since it won't mount. There -is- a "workaround", but it's not for the feint-of-heart. That is, you reinitialize the problem drive. It then looks "empty", but it is not. Yes, you have wiped out the old "directory", but it was corrupted before (that's why it wouldn't mount or show up in Disk Utility). However, the actual data on the drive is "left intact" during re-initialization, SO LONG AS YOU DO NOT ZERO OUT THE DATA (very important).

    Thus the data recovery software can now mount the "empty" drive, and then go to work on it, recovering the actual data that is out on the drive's sectors (and reconstruct those files and save them to the scratch disk). IMPORTANT: you WILL lose all folder hierarchies and many file names, but the consolation is the you'll get the actual data back.

    No guarantees, but this "last resort" approach worked for me when I had a drive with corrupted partitions that would no longer mount.

    A LESSON TO BE LEARNED:
    DO NOT trust your data to only a single backup drive. You need AT LEAST two backup drives. This is where having the USB/SATA docking station becomes very useful. You can swap drives quickly, and even boot from the dock if necessary.
     
  3. swapzr thread starter macrumors newbie

    Joined:
    Oct 27, 2012
    #3
    I checked USB on the System Profiler, and it doesn't seem to show up. What does this mean? I also tried connecting it to my two other laptops (HP) and it doesn't seem to work either. It only confirms that the device is plugged in, but it doesn't give me the option to see any files. Is my HDD waste now?
     
  4. CASLondon macrumors 6502a

    Joined:
    Apr 18, 2011
    #4
    Do you hear your drives spin up normally, no weird sounds, etc.? If so, it could be either the encloser/powersupply or cable or USB port.

    First, reset your SMC and PRAM (google). Then, try to swap the cable, and try to plug it in a different USB port. If it boots at any point in the process, don't dismount but be ready to copy data immediately (so have another disk or enough space)

    If it makes you feel better, I just went through this with 2 previous system backups that I wanted to pull data from. They were in Lacie Porsche enclosures with power issues, so I pulled them to put the bare drives in dock as mentioned above.

    They spun up, but other than my system profiler, nothing else saw them.....not disk utility, not anything.

    I gave them to a friend who does data recovery and is a Apple tech, and he got them to spin up for his system for some reason on his system. So he cloned them for me, and I'm getting a new dock to see if that makes a difference (cheap chinese vs OWC).
     
  5. swapzr thread starter macrumors newbie

    Joined:
    Oct 27, 2012
    #5
    When the drive starts up it sounds normal, but I downloaded the data recovery program Disk Drill and I chose to "Deep Scan" it and as it was doing that (it still is BTW. It says "0hr53m elapsed, ~1259hr12m remains"(increasing as I type this) and I don't know if that means how much time is remaining. It's at .7%) a window from the program came up saying that the External HDD had physical damage in some sectors. And what's SMC & PRAM and how would I go about resetting that?
     
  6. CASLondon macrumors 6502a

    Joined:
    Apr 18, 2011
    #6
    Lots of disks have sectors that are damaged, that by itself isn't the end of the world. I don't know your program, i'd be wary of doing much until I got these things cloned first (are they now mounted ? How can you run a program on them?)


    https://discussions.apple.com/docs/DOC-3603

    Then, importantly, try other USB ports, other cables to rule out hardware issues, you'd be suprised.
     

Share This Page