iMac stops ar grey screen (but accessible via ssh)

Discussion in 'iMac' started by Lestevo, Dec 8, 2010.

  1. Lestevo macrumors newbie

    Joined:
    Dec 8, 2010
    #1
    Hi guys. Today, when I booted my iMac, it stopped at the grey boot screen (no logo or spinner, just a flat grey screen). At first I googled the usual "grey screen of death" options, but I accidentally hit the keyboard of the imac and it made the system bell sound. Some more banging resulted in the screen responding to the brightness controls and it made the volume up/down sounds.

    I grabbed my iPad and ssh'ed into the iMac, and even though I'm a noob at the command line, looking at the TOP command showed the usual bunch of processes running.

    Since the imac is responsive to the keyboard, auto connects to my network and can be reached via ssh, i can only assume the screen itself is borked. Do you have any suggestions or links that could assist me here?

    Thank you.
     
  2. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #2
    Do what I have done when that happens ....

    Disconnect the POWER CORD.

    Wait a minute or two.

    Reconnect the power cord.

    Start it up again!

    ( yeah, it's that simple - or it was for me )
     
  3. Lestevo, Dec 8, 2010
    Last edited: Dec 8, 2010

    Lestevo thread starter macrumors newbie

    Joined:
    Dec 8, 2010
    #3
    No dice. Still got a grey screen. But thanks anyway!

    EDIT: Just reset PRAM and SMC. Still nothing.
    EDIT #2: And now I've reseated the RAM. Still nothing.
     
  4. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    Hmmm ... may need a trip to the Apple Store.

    Mine does what you describe on rare occasions, but the power disconnect reconnect trick works .... so far.

    Good luck ... and post whatever the solution turns out to be.
     

Share This Page