iMac stuck on blank desktop after 10.4 to 10.6 upgrade

Discussion in 'macOS' started by tuna, Sep 1, 2010.

  1. tuna macrumors 6502

    Joined:
    Apr 11, 2010
    #1
    So I just did a clean install of Mac OS 10.6 on an iMac that had previously had 10.4. Everything seemed to work fine and I got through the setup pages and it took me to the new 10.6 desktop and everything was working. I had actually bought the Mac Box Set so I installed iLife, and I ran System Update and it downloaded 1GB+ of updates.

    After System Update was done downloading it said that I needed to restart the computer for the updates to take effect, so I waited for iLife to finish installing, opened up iMovie to make sure it worked, and then I hit "Restart" from the System Update dialog box.

    The iMac has been at a blank OS X desktop since then, for over an hour. By blank desktop I mean that the "purple galaxy" stock background is there, but there is no dock, no toolbar, and no icons, and I can't do anything. At first I thought it was working on installing the updates because the computer was making some disk noise and generating heat, but now its been over an hour and its not making disk noise anymore.

    I'm afraid of forcing a shutdown in case the computer is still installing the update. Is this normal? What do I do?

    If it makes a difference, as I said before this was a clean install. Right at the beginning of the install process I opened Disk Utility, deleted the old partition, and created a new one.

    Thanks
     
  2. Grannyville7989 macrumors 6502a

    Grannyville7989

    Joined:
    Aug 2, 2010
    #2
    That's pretty damn stuck.

    Are you able to hear any hard drive activity on your iMac? If not, then I would say that your iMac is doing absolutely nothing and would be safe to cut the power to it.

    If it continues to hang, boot from your Snow Leopard disc and run Disk Utility to ensure that everything is okay. If not, run the installer again from your the install disc and it should repair whatever is broken.
     
  3. tuna thread starter macrumors 6502

    Joined:
    Apr 11, 2010
    #3
    Problem resolved.

    I ended up calling Apple about it and they said that it seemed like the restart had hanged and they said to force a shutdown. I would have been extremely pissed about that except that, as I said, it was a clean install and I didn't have any data to lose. Turned out fine anyway.
     

Share This Page