iMac taking longer than usual to go in sleep mode

Discussion in 'iMac' started by jlyanks85, Jan 23, 2011.

  1. jlyanks85 macrumors 6502a

    Joined:
    Jan 3, 2008
    #1
    Usually when I put it to sleep, it takes like a half second to turn off. Some reason today it's taking like 25-30 seconds before it finally decide to turn off. What could be the reason for that.

    It still wakes up quickly when I press a button on the keyboard or mouse.
     
  2. chris98vf macrumors regular

    chris98vf

    Joined:
    Mar 3, 2010
    #2
    mine did that last night too, it may just be updating something in the background before it can sleep. If there's any running processes they have to finish 1st. Nothing to worry about unless this turns into an every time thing. Try rebooting it if you're like me and leave it running for weeks at a time with only using sleep.
     
  3. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #3
    Most of the time I've put it in sleep today, I had nothing running. I quit everything before I put the mac in sleep.

    Never did this before until today.
     
  4. chris98vf macrumors regular

    chris98vf

    Joined:
    Mar 3, 2010
    #4
    does it do it every time now? Even if all is closed out it may be doing something in the background you don't know about, checking for updates and such. If it's doing it every time maybe you can run a defrag. Google how to do that on a mac because that's what I would do if I had any more energy left this weekend lol.
     
  5. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #5
    Just about every time now. Maybe a couple times, it'll go to sleep quickly. When all the programs are closed. All the other times it'll take like 15-20 seconds before goes to sleep.
     
  6. chris98vf macrumors regular

    chris98vf

    Joined:
    Mar 3, 2010
    #6
    any major changes? install a new app? install an update from Apple? run a hardware diag if a defrag doesn't do the trick. Don't forget to always back everything up. If all else faild a clean install of OS X fixes all :cool:
     
  7. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #7
    The only thing I did different today was fix a couple settings on my sisters laptop, because the wireless printer wasn't printing for her for some strange reason. The wireless printer is in my room where my imac is.

    I doubt that has to do with anything, but that's the only thing I did different. Everything was fine last night and everything else is now expect for it taking a long time to go in sleep mode.
     
  8. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
    #8
    Sometimes certain programs are slow to respond when commanding the computer to go to sleep, or the computer has to do some sort of daemon before it feels it should go to sleep.

    IF there were a problem, it'd most likely be software related, but I've had macs over the years, and they do take a while to sleep from time to time. I wouldn't worry about it, unless you can confirm it's doing it every single time you try to put it to sleep (even after a restart)
     
  9. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #9
    Well right now it is taking about 20-25 seconds to go to sleep even after I restart it, shut it down and turn it back on, etc.

    This was never a issue for me until this afternoon.
     
  10. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
    #10
    Check your activity monitor/console log to see if there's any daemon for that printer.
     
  11. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
  12. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
  13. Cboss macrumors 6502

    Joined:
    Dec 11, 2008
    Location:
    Colorado
    #13
    I had this happen for a few months before I finally solved it. My problem was that I had a printer job that wasn't cancelled on a rarely used printer.

    Go to:
    System Preferences -> Print & Fax

    Then, select each printer that is listed and click the "Open Print Queue" button. If there are any printer jobs in the queue, select them and push the delete button.

    Hopefully this will fix your slow sleep issues, like it fixed mine.
     
  14. DanielCoffey macrumors 65816

    DanielCoffey

    Joined:
    Nov 15, 2010
    Location:
    Edinburgh, UK
    #14
    I see you have already tried the Shut down and Restart option. That would have been my suggestion to clear anything out. I hope you get it sorted.
     
  15. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #15
    I just checked this, and nothing is in my printer jobs. Just says "printer ready. I'm running out of options here and the computer is still taking around 20-30 seconds to go in sleep mode.
     
  16. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #16
    This is not something I wanted to go to apple for, but I might have no other choice right now.

    Everything I tried isn't working. Every couple times it'll go to sleep quickly, but all the other times it takes 20 or so seconds.
     
  17. Cboss macrumors 6502

    Joined:
    Dec 11, 2008
    Location:
    Colorado
    #17
    There's a terminal command to find out what is happening while it's going to sleep. I can't remember what it is off the top of my head, but I'll edit this post later if I remember it.

    Edit:
    I found it. Paste:

    pmset -g log

    into the terminal and check the response times on everything listed. Anything under a thousand or two ms shouldn't be causing the problem.
     
  18. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #18

    Ok I tried this, and starting looking when the issue started which was yesterday.

    This came up alot of the time:

    * Domain: applicationresponse.timedout
    - Message: Kernel cupsd com.apple.powermanagement.applicationresponse.timedout 30000 ms
    - Time: 1/23/11 2:56:31 PM EST
    - Signature: cupsd
    - UUID: 79B7820A-C020-4FE6-B00C-D04B298BA45C
    - Result: Noop
    - Response time (ms): 30000


    This came up a couple times as well:

    * Domain: sleep
    - Message: Sleep: Apps Failure - AC
    - Time: 1/23/11 3:15:12 PM EST
    - Signature: Apps Failure
    - UUID: C4DA5603-D690-4697-A02C-A2ABEE4A905D
    - Result: Failure

    And this: * Domain: applicationresponse.slowresponse
    - Message: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 222 ms
    - Time: 1/23/11 3:16:40 PM EST
    - Signature: AirPort configd plug-in
    - UUID: F1444713-8D7D-4023-8348-98165950B307
    - Result: Noop
    - Response time (ms): 222

    Then the few times it went off quickly it had this:
    * Domain: sleep
    - Message: Sleep: Success - AC - Software Sleep
    - Time: 1/23/11 5:45:50 PM EST
    - Signature: Success
    - UUID: 093C44D3-A0BE-40E8-838B-8FC72C148F07
    - Result: Success

    Don't know what any of that means, but from reading some of those words, it does look like theres a problem. The ms in some of the numbers today was all over the place, sometimes it said 5000, others under 1000.
    - Sleep count : 6
     
  19. Cboss macrumors 6502

    Joined:
    Dec 11, 2008
    Location:
    Colorado
    #19
    Here's the culprit. It's waiting 30 seconds for this to timeout before it sleeps. I don't know how to fix this specific problem (if it's not what I suggested earlier), but at least you've got it narrowed down a bit.

    Maybe try pausing your printer or turning it completely off. Probably won't help, but you never know.

    cupsd is related to printing. Which makes sense since this stated happening after doing some new printer stuff.
     
  20. jlyanks85 thread starter macrumors 6502a

    Joined:
    Jan 3, 2008
    #20
    All this time of searching on the internet on how to fix it, I just thought about it in my head a couple hours ago and it worked. Uninstalling the printer software, then reinstalling it.

    I knew it had something to do with the printer and it goes to sleep right away right now. Thanks for all the help.
     
  21. ndriver182 macrumors 6502a

    Joined:
    Jun 26, 2007
    #21
    You, my friend, are amazing. I was just considering getting off my lazy butt to figure out why my iMac had been taking soooo long to go into sleep mode over the last several weeks. I happened to come across this thread by chance tonight and saw your post. What do you know, stalled print job from NOVEMBER 2010! Deleted it. Instant sleep mode returns. Simply awesome. Thanks again!
     
  22. bketchum macrumors regular

    bketchum

    Joined:
    Jan 15, 2003
    Location:
    Grand Portage, Minnesota
    #22
    Hey, Cboss, your tip worked for fixing my slow-to-sleep iMac. Thank you!
     
  23. brickyard34 macrumors newbie

    Joined:
    Oct 5, 2013
    #23
    Update since 1st inquiry

    I realized the postings for this problem are old. I was experiencing the problem with my new iMac. I found the if I didn't "Quit" Chrome before selecting sleep the shut down times was 30 seconds, when I quit Chrome it took a second.

    Hope this is of value. :apple:
     
  24. dcell macrumors member

    Joined:
    Nov 6, 2010
    #24
    i have this problem too since a few weeks. It's indeed Chrome that is somehow delaying the sleepmode.
     

Share This Page