iMac thinks Magic Mouse is a wireless Mighty Mouse

Discussion in 'iMac' started by Cave Man, Dec 14, 2009.

  1. Cave Man macrumors 604

    Cave Man

    #1
    My new Magic Mouse appears as a wireless Mighty Mouse on my iMac 10.6.2. When I open the mouse Preferences Panel, I get the options for the Mighty Mouse, not the Magic Mouse. It worked fine on my hackintosh with 10.5.8 but not with 10.6.2, so it seems the culprit might be in 10.6.2? It seems that USB Overdrive is the culprit for some, but I don't have it. Any ideas?
     
  2. Trek2100 macrumors 6502a

    Trek2100

    Joined:
    Oct 20, 2009
    Location:
    Catonsville, MD
    #2
    This is what is listed on Apple's website:

    A Bluetooth-enabled Macintosh computer
    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0* or Mac OS X v10.6.1 or later with Wireless Mouse Software Update 1.0

    I saw this problem on another thread but I don't remember where. Can you check to see if you have the "wireless mouse software update 1.0"? Perhaps check "software update" with the magic mouse turned on.

    Try reading this thread. Don't know if this will help:

    http://discussions.apple.com/thread.jspa?messageID=10546736?
     
  3. Cave Man thread starter macrumors 604

    Cave Man

    #3
    I tried to install the Wireless 1.0 update on 10.6.2, but the installer objected, stating that I had a "newer version" of the software. I wonder if I forced the issue with Pacifist?
     
  4. moteltan macrumors newbie

    Joined:
    Jan 5, 2008
    #4
    Anyone ever resolve this problem? It's 2011 and I finally inherited a magic mouse after my wife went to the trackpad on her computer. I'm experiencing this same problem.
     
  5. Brasshat macrumors newbie

    Joined:
    Sep 30, 2010
    #5
    I recently installed 10.6 on a 2009 iMac. My new wireless mouse showed up as an older model until I updated software to 10.6.6.
     

Share This Page