iMac timing out

Discussion in 'iMac' started by audiophile249, Sep 8, 2010.

  1. audiophile249 macrumors newbie

    Joined:
    Jul 30, 2009
    #1
    When i try to download updates to my itunes it times out. I am on a wireless network and have looked for a way to extend the time. I have googled this without much success. Anyone know how to fix this. Thanks
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What Mac OS X version and iTunes version do you use and which exact update versions do you download how from where with what?
    Btw, what are your network settings? And does it only happen with iTunes updates or are other downloads affected too?
     
  3. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #3
    Unknown to many, MBP and iMac platforrms don't like to "wireless" with some wireless equipment. Some say its the ISP, some say its the MAC OS, some say its lack of solid "hand shaking" across different vendor products, and some say its for other reasons. Regardless, there is a few known fixes to resolve slow access / dropped sessions.

    Customize 1 - Change the MTU size on your iMac. For more details, surf:

    http://help.expedient.com/broadband/mtu.shtml
    http://www.zen.co.uk/Support/Tools.aspx

    If wondering, I changed my iMac's MTU size to 1492 (same as my ADSL Modem / Wireless "2Wire 1701 box" MTU "fixed value" size) and it works great.


    Customize 2 - Don't use WEP. Unknown to some, small amount of Mac workstation's don't like WEP (which is Bell - Sympatico's suggested) Wireless configuration for Macs. As a suggestion, change to WPA or WPA2 and if possible, enable MAC Address Filter security within your Router as well. Thus, enabling both text "key" and H/W Address security layers. If you must go with WEP (because other wireless devices can only use WEP), do use MAC Address security on your modem / wireless device as well. But when possible, use WPA2 for wireless security.

    For more details about WAP2, surf:

    http://www.youtube.com/watch?v=di19ZgVhHH8

    http://www.youtube.com/watch?v=q0ZqQuTYwEk


    Customize 3 - Customize Router defaults.

    With many wireless boxes, their wireless power level default is often set at 5 (10 being max). Set to 8 and "give it a try". Also, your wireless might also be set for 802.11 B/G (mixed). Set it for 82.11B and "give it a try". If stable, then set to 802.11G. Give that a try. Some modems don't like using B/G mixed with some end devices. If wondering, I set my 2Wire and iMac with "only G" and it works great.


    Customize 4 - Don't use Mac workstation Security - Firewall (for now). For some small number of Mac workstations, Firewall on Home's Router and Firewall on Mac platform can "conflict" with one another. For now, turn Mac's Security-Firewall OFF (if your Modem/Gateway also has Firewall enabled). Only turn Mac workstation's Firewire ON (enabled) AFTER all other things work great.


    If all these customizations fail, one can also manually change the "delay" values with Mac's SMB.INF file. But that's for advanced users. The above items are "simple changes".


    IMO.... For 9 times out of 10, the mixture of wireless 802.11B/G and improper MTU settings (default of 1500 value) are the majority of slow, dropped wireless / internet and "time out" session problems.


    Hope this helps....
     
  4. Spike88 macrumors 6502a

    Joined:
    Jan 25, 2010
    #4
    To set MTU within my iMac 21.5", I used a free MTU size Discovery / Set utility. With this tool (saved in my iMac's Applications - Utility folder) , I manually set its MTU on all ports (ethernet, wireless, firewire, etc.) only once. Set it once and its done.

    This script can be found at:

    http://tumbleseed.wordpress.com/products/set-mtu/

    Note: Click on its "Download the Set MTU 0.2 script application (zip)" text - to obtain the script file.

    And yes, this script works great on mid-2010 21.5" iMacs using SL as well.

    Hope this helps as well...

    .
     

Share This Page