iMac unable to connect to existing home wireless network

Discussion in 'iMac' started by bodanzarama, Feb 6, 2010.

  1. bodanzarama macrumors newbie

    Joined:
    Feb 6, 2010
    #1
    Hello to anyone who might be able to help.

    We have a PC in the upstairs office with cable/DSL router for Internet (through Comcast). This service also has a wireless connection. We have a Macbook laptop which connects effortlessly to our home network and we use it all over the house. We simply clicked the internet symbol on the top right (looks like a little amphitheater), selected out network, entered the password and have been connected ever since.

    Today we brought home a new iMac and set it up in basement office. Tried the same routine. Clicked on the internet symbol, selected our network, noticed that the signal is just as strong as it is upstairs, typed in password but that's as far as we get.

    I've gone the rounds with the Assist and the Utility features. I've shut the Airport on and off. I've tried setting up a new network. I do notice that the iMac has a "self-assigned" ISP "and cannot connect to the Internet." Does this mean I can't ever connect? Do we need to replace the self-assigned ISP with our Comcast IP address?

    I've read here and there that our router might have Macs blocked and we could add this iMac as a secure system to get on the network. But we haven't played with the router's settings because we wouldn't know how. Besides, the Macbook connects fine.

    Does this have anything to do with TimeMachine?

    I'm overlooking something really basic, right? We're going in circles with the help available on the iMac. :confused:

    Any advice? Very much appreciated!:)
     
  2. MMM.PWR macrumors 6502

    MMM.PWR

    Joined:
    Sep 21, 2009
    Location:
    Chicago
    #2
    You're not getting any answers here, might want to try the networking section.

    I didn't have any issues getting my first iMac connected, it should be the same as on any other Mac including your MB. Some of these modems with built in routers do give Safari issues though. I know mine did (2wire) until I disabled the routing feature and bought an Airport Extreme for my 2 networks.
     

Share This Page