iMAC update "software not supported on your system"

Discussion in 'Mac Apps and Mac App Store' started by datadriven, Feb 1, 2014.

  1. datadriven macrumors newbie

    Joined:
    Feb 1, 2014
    #1
    have an iMAC 10,1 which is supposed to be updatable through Mavericks.
    Previously had a network administrator, but this network system has been discontinued. So have Snow Leopard 10.6.3 now.
    When download even 10.6.4, the installer says that "this software is not supported on your system".
    Updater button itself does not work, saying there is a network problem, but trouble shooter says it is working fine (direct connect for internet service is fine).

    Any ideas?
    Thanks in advance.
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
  3. datadriven thread starter macrumors newbie

    Joined:
    Feb 1, 2014
    #3
    get the same message

    Unfortunately, I get the same "not supported" message when trying to run the suggested update.
    Hard to imagine why that is, unless it has something to do with the former network set up.
    DD
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Give us some more information:
    Go to the Apple menu, then About This Mac.
    What is the version number under the Mac OS X line?
    Then, click on that version number (it will change to another value), until you see the build number.
    Should be something like 10D578, but need to know the exact number.

    Click on the More Info button, and verify what the Model Identifier is…

    Another tip is to restart your iMac, holding the Shift key. That will boot into Safe Boot mode. You will get a login window, even if you don't normally have one, so log in to your account.
    Then, try to install that combined updater 10.6.8 that you have downloaded.
     
  5. datadriven thread starter macrumors newbie

    Joined:
    Feb 1, 2014
    #5
    safe mode update effort gave same message "not supported"

    Version # 10.6.3
    Build @ 10D573
    Model Identifier iMAC10,1

    Tried the updater install and got the same message in Safe Boot Mode.

    Thanks again.
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    I haven't looked this up but this could all be due to the iMac having been once managed via Mac Server (I presume). The server admin might have had control over updates and the iMac dependent on the server for updates.

    I haven't tried updating an orphaned Mac but it sounds like something that might happen.

    Most reliable thing to do would be backup, format and reinstall 10.6, update to 10.6.8 then upgrade to 10.9 Mavericks.
     
  7. datadriven thread starter macrumors newbie

    Joined:
    Feb 1, 2014
    #7
    Brian, thanks a lot for the advice.
    I redownloaded the 10.6.8 update in safe boot mode, and although the final "minute" of installation took more than an hour (I left it overnight at that stage rather than giving up), it finally went through!
    I'll try the Mavericks next, also in safe boot mode, which seems to overcome the server admin problem.

    Grazie mille!
     
  8. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    Just in case, backup all your data (Time Machine, clone) before installing Mavericks.

    You can also use Disk Utility to repair the permissions before installing Mavericks, and after installing as well.
     

Share This Page