iMac USB problems.

Discussion in 'iMac' started by Jasonbot, Aug 29, 2007.

  1. Jasonbot macrumors 68020

    Jasonbot

    Joined:
    Aug 15, 2006
    Location:
    The Rainbow Nation RSA
    #1
    I'm having some USB power problems with my iMac 20" (late 2006)

    So to start, my iMac has 3x USB 2.0 ports of which:
    • 1 has my 3.5" eternal HDD plugged in (it has its own power)
    • 1 has an extension plugged in so that I can plug in flash drives
    • 1 has a 4 port USB Hub plugged in. It doesn't have its own power source. plugged into this is:
    • a printer (off most of the time)
    • iPod shuffle dock
    • iPod dock
    • Keyboard (mouse plugged into keyboard)

    I havent experienced problems in the past. I can plug in two iPods into both the docks and not experience problems but the problem comes in when I plugged a 2.5" external HDD into the USB extension. The problem was that I couldn't use the mouse. I had full keyboard control and the mouses' optical light was still on. It was just unresponsive on screen.

    Is my USB setup underpowered? or is there some other problem?

    Also; is USB power given per port or does the entire system have a limit?
     
  2. Jasonbot thread starter macrumors 68020

    Jasonbot

    Joined:
    Aug 15, 2006
    Location:
    The Rainbow Nation RSA
    #2
    Ok, since no one knows about my problem how about a simpler question:
    Does anyone know anything about the USB spec of the late 2006 iMac's?
     
  3. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #3
    I'd guess it would be the un-powered hub causing problems.
     

Share This Page