iMac volume control issue

Discussion in 'iMac' started by gnagy, Jun 28, 2011.

  1. gnagy macrumors regular

    Joined:
    Sep 7, 2009
    #1
    I have a new 27" sandy bridge iMac with 3.4Ghz core i7. It's running OS X 10.6.8.

    When I press the F11 and F12 keys on the keyboard to adjust the volume level, the volume control thing pops-up. I can even light up or turn off the little rectangles, but the volume level does not change. If I go all the way down, I'm able to mute the speakers.

    The only way I can control the volume is using the System Preferences->Sound->Output Volume slider. On my other mac computers this slider moves when I press the F11 and F12 keys, but not on this new mac.

    Does anyone have any ideas what might be wrong? It's starting to drive me nuts. Having to open System Preferences every time to change the volume is not convenient.
     
  2. FACADE macrumors newbie

    FACADE

    Joined:
    Feb 1, 2010
    #2
    Open system preferences>keyboard. Be sure that the box "Use all F1, F2, etc. keys . . . " is unchecked.
     
  3. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #3
    as the above poster mentioned, try that. do you have any external speakers plugged into the iMac itself? if so they need to be turned on and their volume needs to be at an audible level.
     
  4. gnagy thread starter macrumors regular

    Joined:
    Sep 7, 2009
    #4
    The problem I have is very bizarre. This is my 2nd 27" iMac, and the old one works just fine.

    Facade, the check-box is unchecked.
    AppleNewton, I'm using the iMac's built in speakers.

    Like I said, the system preferences->sound page has an "output volume" slider, which works fine to control my volume.

    The F11 and F12 keys also seem to work. The volume thing pops up, and I'm able to mute the speakers. But there are just two volume levels when I use the function keys. Muted and very fricking loud, and nothing in between.

    I might just have to take it to the Apple store.
     
  5. Dan2142 macrumors newbie

    Joined:
    Jun 20, 2011
    #5
    Volume Problem

    Depending on what Mac version you have there should be a small speaker icon in your toolbar at the top right of your screen, you can adjust the volume from there. Also try configuring your keyboard so that two of the keys are clear (unused) so that you can make them the volume control keys.:)
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  7. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #8
    Try plugging in a set of Headphones into the headphone jack once, then remove them, Do the same with the MIC jack (if it has one) then remove it again.

    I have run into this issue with my MacBook Pro a couple of times. I am not sure if the switch inside the jack (telling it headphones or a speaker is connected) is malfunctioning, or if it is software.

    if that doesn't work, try plugging in a set of headphones and see if the volume responds normally too.
     
  8. gnagy thread starter macrumors regular

    Joined:
    Sep 7, 2009
    #9
    This worked! Thanks.
     
  9. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #10
    No problem. Glad I could help.
     

Share This Page