iMac wakes automatically after I've put it to sleep

Discussion in 'iMac' started by DrewPulidoI, Sep 15, 2011.

  1. DrewPulidoI macrumors newbie

    Joined:
    Sep 15, 2011
    #1
    So every time I try to put my comp to sleep it awakens automatically. It started about 2 days ago and I can't find the reason. It seems a little hotter than usual.


    Mac OS X 10.5.8, Have regular mouse and keyboard that came with it, I've unchecked the "Wake for ethernet" box in energy saver, I reset the PRAM, sharing is off.

    I'm not sure what else to do :/ can anyone help?
     
  2. Sepp macrumors member

    Joined:
    Aug 7, 2010
    #3
    not sure if applicable here, but I have had the same issue...it was the SSD drive (OCZ Vertex). It died, and with the original HDD everything's fine again.
     
  3. DrewPulidoI thread starter macrumors newbie

    Joined:
    Sep 15, 2011
    #4
    GGJstudios: I've tried the steps in the first link but nothing. The second link I actually am clueless of what the code I received means (Thu Sep 15 22:05:37 andrew-pulidos-imac-2 kernel[0] : Wake reason = EC)

    Sepp: So what could do? Just wait for it to die? I'm not to sharp when it comes to computers.:eek:
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    From that link:
    So, do you have a USB or Bluetooth mouse or keyboard or other wireless device that you use with your Mac? If so, that may be the reason it's waking. Try turning off any wireless mouse or keyboard.
     
  5. DrewPulidoI thread starter macrumors newbie

    Joined:
    Sep 15, 2011
    #6
    no i have the basic keyboard and mouse that came with the iMac(wired) i've tried turning bluetooth and airport off. I sleep the computer and it still automatically wakes up. So all night I can hear it working unless I shut it down :\
     
  6. TheMirrorsTruth macrumors newbie

    Joined:
    Jul 11, 2011
    #7
    Your iMac has become self-aware. You need to throw it into a vat of molten steel before it's too late.
     
  7. neilmacd macrumors 6502

    Joined:
    Apr 18, 2010
    Location:
    UK
    #8
    Same problem...

    Press sleep, 2 hours later its awake again. Hours of googling and nothing has helped.

    Reason for wake is always RTC maintenance alarm and it's always around 2 hours later. Unlike it's intended use, my mac does not go back to sleep soon after it does it's 'maintenance', it just stays awake.

    Have deleted .plists, messed with energy saving settings, even reset PRAM etc.

    I cannot untick wake for network access as I VNC my iMac all the time.

    So it's either leave it powered on or turn it off completely. :mad:
     

Share This Page