iMac wakes from sleep same time every night

Discussion in 'iMac' started by will0407, Jan 9, 2008.

  1. will0407 macrumors 6502a

    May 20, 2006
    My iMac for the last 4 nights, has woken from it's sleep status at 6:30 in the morning. Does anyone have any idea why this would be? It only has my stereo, and mouse physically connected, and a bluetooth kybd.

    it's a 20" 2.4ghz alu imac.

    Any help would be great (so I can get a proper nights sleep for a change!)
  2. xUKHCx Administrator emeritus


    Jan 15, 2006
    The Kop
    Check here

    System preferences - energy saver - schedule

    If nothing is set there then reset your PRAM by holding down cmd+option+p+r at boot.
  3. will0407 thread starter macrumors 6502a

    May 20, 2006
    ive got nothing set in energy saver, so will try the pram, and then find out if it's worked at 6:30 tomorrow!
  4. will0407 thread starter macrumors 6502a

    May 20, 2006
    I reset the pram, put the imac to sleep, then about 5 or 6 minutes later, it woke from sleep, so i just shut it down.

    Does anyone have any other ideas why this is happening, or how to fix it?
  5. ray648 macrumors regular

    Jan 10, 2008
    I had a similar problem for a while on my 24" imac. It would wake me up in the middle of the night when woke itself up from sleeping. The problem was caused by the bluetooth mouse. If I turned the mouse off, it would wake up in the night and complain about there being no mouse. I solved the problem by just leaving the mouse switched on.
  6. Jimmdean macrumors 6502

    Mar 21, 2007
    If you have a wireless mouse it could be because the battery is running out...
  7. will0407 thread starter macrumors 6502a

    May 20, 2006
    i have the bluetooth alu keyboard, and a USB mouse, so i don't think it's the mouse thats the problem. I may try taking the batteries out of the keyboard and see what happens.
  8. crobbins macrumors 6502


    Nov 11, 2006
    Perhaps it's having nightmares? Sorry I couldn't resist..I think the best bet is trying the batteries in the keyboard..
  9. daneoni macrumors G4


    Mar 24, 2006
    Ah....its most likely the BT keyboard. Go to Bluetooth press and make sure 'Allow Bluetooth Devices to wake this Computer' is unchecked

Share This Page