iMac wakes up on its own

Discussion in 'Mac Basics and Help' started by philipe1959, Oct 3, 2013.

  1. philipe1959 macrumors newbie

    philipe1959

    Joined:
    Sep 2, 2012
    Location:
    Cardiff S.Wales
    #1
    Can anyone help when I finish with my mac and it shuts down after about 4 hrs it wakes up by itself is this anything to do with the Power management and if so how do I change it
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    What does System Preferences->Energy saver say in your Mac? Plus what to the logs (/Applications/Utilities/Console) say about the waking up?
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    Is it your own computer or a company computer?

    Look into
    System Preferences > Energy Saver > Schedule
     
  4. philipe1959, Oct 3, 2013
    Last edited: Oct 3, 2013

    philipe1959 thread starter macrumors newbie

    philipe1959

    Joined:
    Sep 2, 2012
    Location:
    Cardiff S.Wales
    #4
    Its my own computer

    ----------

    The energy saver is set to Computer sleep 30 mins, and Display sleep 25 mins. and 1.Put the hard drive to sleep when possible, 2. Wake for network access, 3.Allow power button to put computer to sleep are all ticked.

    I have looked in the console and there is nothing about waking up or if there is where will I find it ???
     
  5. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #5
    System Preferences > Energy Saver.

    Look for a "Schedule..." button at lower right.

    Click it.

    What does it show?
     
  6. philipe1959 thread starter macrumors newbie

    philipe1959

    Joined:
    Sep 2, 2012
    Location:
    Cardiff S.Wales
    #6
    There is nothing ticked and the time is set to 00:00
     
  7. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #7
    Todays EFI updates may have addressed some of these issues, but they are well documented. See the information in my thread here:

    http://forums.macrumors.com/showthread.php?t=1529750&highlight=imac+wake+from+sleep+issues

    Preventing the Mac from sleeping has helped many here. I have installed the update for ML on my Imac and rMBP but have yet to test things out. I will post back in the thread if the update has cured this.

    I have not yet messed with my MP as it has a custom setup I don't want messed around with...Runs 24 / 7 as a server anyway.

    ----------

    Further information on the update to ML can be found on the front page article here:


    http://forums.macrumors.com/showthread.php?p=18072708#post18072708

    I have returned the Imac to it's factory power settings ( reverse the terminal command's in the thread I posted above) and have left it to see what happens...Can't sleep, so will keep an eye on it now.
     
  8. philipe1959 thread starter macrumors newbie

    philipe1959

    Joined:
    Sep 2, 2012
    Location:
    Cardiff S.Wales
  9. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #9
    Others said it might be a known issue. But I would try to uncheck "Wake for network access" and test.
     
  10. philipe1959 thread starter macrumors newbie

    philipe1959

    Joined:
    Sep 2, 2012
    Location:
    Cardiff S.Wales
    #10
    Problem Sorted

    If anyone has the same problem then I found the answer from Macman45 if you cant get hold of him then here is how it was explained to me, you need to go into your Applications folder then Utilities, then Terminal, and type sudo pmset autopoweroff 0 and sudo pmset standby 0 this will sort it out for you as it worked with my mac also when you finish typing the command you will be asked for the system password this is the one you set up on your mac when you first had it.

    Hope this will help anyone who is having the same problem I had. Good Luck :):):)
     

Share This Page