iMac waking up from sleep all the time

Discussion in 'iMac' started by Chris 123, Jun 6, 2010.

  1. Chris 123 macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
    #1
    I almost always put my iMac to sleep every night. Ever since about a week ago it started waking up, and waking me up, in the middle of the night. And yes in that week I have tried shutting down and it still does it the next day.

    I don't have any apps open that I don't normally, didn't change any settings i'm pretty sure.

    I tried the list from apple that lists reasons it would wake unexpectedly and googled but nothing works. Just thought maybe one of you has had a similar problem. Thanks
     
  2. Merk328 macrumors newbie

    Joined:
    Jun 6, 2010
    #2
    i feel ur pain

    I had the same issue happening to my 20' iMac circa 2007. I let mine go on for months though. I tried everything under the sun to get this to stop but nothing seemed to work. Eventually i broke down and called applecare about the issue. They tried a few tricks up there sleves, but each attempt was to no avail. Finally i got them to take a look at it at an Apple store and they had no clue either. **actually the "genius" that helped me tried to convince me that sleep was bad for my Mac and that its dumb. I told him that one of the main reasons i bought a Mac was because i didn't have to shut it down hardly ever.** anyway, The wiped my whole hard drive and rebouted the whole thing back to factory specs. Ever since i have not had 1 issue.

    Moral of the story: Just make an appointment with the Genius bar and make them fix it. Utlimately, even if you have to pay, it is horrible on ur Mac for it too keep comming in and out of sleep constantly like it does.
     
  3. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
    #3
    Wake for network access?
    Bluetooth keyboard or mouse battery excessively low?
     
  4. Chris 123 thread starter macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
    #4

    Thought it might be a case like this...ughhhh

    Thanks for sharing.
     
  5. Chris 123 thread starter macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
    #5
    You may have just saved me. Wake for network access was checked, but I still don't know why it wasn't doing it for months. I'll see if it does it tonight, I just unchecked it

    Thanks
     
  6. DisneyRicky macrumors regular

    DisneyRicky

    Joined:
    Jun 5, 2010
    Location:
    Northern California
    #6
    Network Access? That's possible, and also there is a feature that makes it turn on at a certain time. It's under your energy settings (?), you can have your iMac automatically turn on at a certain time.
     
  7. TMRaven macrumors 68020

    TMRaven

    Joined:
    Nov 5, 2009
    #7
    I had my iMac wake up on me earlier this morning to notify me my bluetooth keyboard was low. Waking for network access isn't too disruptive, as it only revs up the hdd for a little time, never turns on the display, then the computer goes back to sleep 5 seconds later. Waking up to warn you your bluetooth device is low on batteries is pretty disruptive though.
     
  8. ReggaeFire macrumors 6502

    Joined:
    Mar 19, 2003
    #8
    Usually when this happens there is an application that is waking the machine up. Go into Activity Monitor and start one by one killing application processes, especially if they're "Helper" processes. An old version EyeTVhelper used to hang on my machine and not allow it to sleep. I've also had the issue with a background process by TechTool waking the machine.
     
  9. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #9
    My iMac started waking up all the time. Wake for network access was turned on because I was using it as a printer server, so turning that off wasn't an option. But it turned out it was Bots trying to hack into my ssh port (I had ssh open so I could access the system from outside my home.) Turning off ssh port forwarding stopped the problem and now the ssh gets forwarded to a server that runs 24/7 anyway.

    I've used sleep on virtually all my computers for the past decade, Macs and PCs. Most often failure to stay or go asleep has been caused by troublesome mice or printers that seem to panic and wake the computer if it tries to sleep. The problem can be solved with a different mouse or connecting the printer via a powered USB hub.
     

Share This Page