IMAC White Screen of Death! Help!

Discussion in 'iMac' started by clownfish33, Feb 25, 2012.

  1. clownfish33, Feb 25, 2012
    Last edited: Feb 25, 2012

    clownfish33 macrumors newbie

    Joined:
    Feb 25, 2012
    #1
    I upgraded my 2007 iMac to Lion and after a few days of perfect running the thing locked up. When I forced the power off and back on it seemed to be booting fine (chimes, apple logo, disk spinning up and I could hear the drive head seeking) but then it froze up in the "White Screen of Death" (WSOD). It was completly lockd up again, and nothing would bring it back. I had to reboot again. And again. Everytime it seems to be starting ok, but then locks up after it the screen goes white. . I did command option , p r keys with three chimes. I have unplugged it and let it sit. I disconnected all periferals including my Time capsule. I reset the SMC. I booted into Single User mode and used unix commands to check the HD. No errors found.

    Note that it appears to be booting fine at first with the usual grey Apple Logo. And when I boot into the Single User mode all the text indicates no faults. The display and HD appear fine.

    I then replace both RAM chips. No change.

    I inserted my original OSX Leopard disk and and tried to boot from it, using the "C" boot process and the Option boot method to manuualy select the DVD. No good. It just went into the WSOD again.

    I inserted the Lion Thumbdrive that Apple sent me. It too started to boot as normal - but then after a minute I get the WSOD.

    I booted in using the "T" target disk mode. That worked, to mount the HD up on my Macbook. I scanned the HD and no repairs where needed. I then trid booting again. No luck. So I erased (and zeroed) out the HD and trie dto boot from the DVD again. Nothing changed. I still could not completely boot up the install disk or thumbdrive.

    Now I have a brick. A very large and heavy brick.

    I have no idea what to try next!
     
  2. rayward macrumors 65816

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #2
    I have a 2011 i7 iMac, and am having the exact same issue. It started slowing up, having trouble reacting to keystrokes and processing work, so I left it alone. When I came back to it, I had the WSOD with the gray logo and spinning gear. I forced a reboot and got stuck at the same point (I was leaving it for hours and getting nothing).

    One time, it did reboot, but was acting the same as it did just before the original error. I haven't got it to boot since. Same as the OP, it chimes and shows the logo, but then sits there with the spinning gear.

    I did a shift-control-v boot to see what was happening in the background. It went through some activity, then started checking the disk. It has a line that stated "14 major, 2 minor", which I am worried refers to disk errors. After that, it seemed to be going block by block and recording a series of errors, all the same, like this:

    Disk 0s2: I/O Error:
    0 [Level 3] [ReadUID0] [facility com.apple.system.fs] [ErrorType IO] [ErrorNum 5] [IOType Read] [PBlkNum 1595372336] [LBlkNum 40242]​

    It looked like it was repeating the P & L block numbers, but then started to count up to higher numbers. I was not there when this process finished (hours), but when I went back, I had the WSOD, logo and spinning gear.

    I'm out of ideas too.
     
  3. camardelle macrumors 6502

    Joined:
    Aug 17, 2011
    Location:
    Texas
    #3
    If you still have your applecare, take to a genius maybe?
     

Share This Page