iMac white screen

Discussion in 'iMac' started by Bravia3d, Nov 9, 2013.

  1. Bravia3d macrumors member

    Joined:
    Nov 9, 2013
    #1
    Hello guys, I am new to the forum and having iMac problems.

    First off it's a 27in 2011 model with a 250gb ssd drive and a 1tb drive.

    I have Windows 7 installed on both drives and Mac OS also installed on the 1tb drive.

    It has been working fine until 3 days ago I was watching a video on IGN's website and then all a sudden it went all white and froze.

    Now it will not load any OS, it acts like it will load up but on windows the screen turns and stays black. On MAC OS it turns white.
    I am able to hold alt and choose the drive, but each still goes black or white.
    I have tried key commands and all I can do is load Windows in safe mode and nothing more. It will not allow anything more.
    I stuck the Mac OS disc in and tried loading off of it, but after the apple logo it goes white and stays that way.

    I have unplugged everything and tried, but no luck. So at the moment I have a $3,000 paper weight. Not sure what could be wrong?
     
  2. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #2
    First off, did you install the SSD? If so, I'd open her up again and check to make sure all plug connectors are seated and tight. Is the Windows 7 OS it boots from on the SSD? And even in "Safe Mode" can you check under "Computer" in Windows 7 to see if both drives are seen?

    If it doesn't even boot off the DVD that came with the Mac, that's not a good sign. If it's not a loose connector, then I'd bring it to Apple to have them test it. From your description, it could be a Logic Board problem.
     
  3. Bravia3d thread starter macrumors member

    Joined:
    Nov 9, 2013
    #3
    Thanks for the reply, no I didn't install it myself. The ssd was already installed with the Mac.

    I have windows 7 boot off both the ssd and my 1tb hd. I have 2 windows 7 installed, one for my work and the other just to browse the net and download files.

    Checking under Windows 7 safe mode I can see both hard drives.

    I can only get into safe mode on windows. I can hold alt and try loading Mac OS but it goes to the white screen, powering off and reloading try's to load Windows again. I can't load safe mode in Mac OS. Won't load the disc still either.
     
  4. Bravia3d thread starter macrumors member

    Joined:
    Nov 9, 2013
    #4
    Took it to Apple, it was the graphics card and they are going to fix it for free.
     
  5. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #5
    If I'm not mistaken, some Sandy Bridge mid-2011 27" iMacs did have a graphics issue, and Apple issued a service advisory notice to users, offering a free graphics replacement.
     

Share This Page