iMac wifi broken?

Discussion in 'iMac' started by mick564, Dec 18, 2010.

  1. mick564 macrumors newbie

    Joined:
    Dec 18, 2010
    #1
    Hello,
    This week my iMac wifi suddenly got very slow, a website like google takes 5 minutes to load when normally it took seconds.
    At first i tought it was a software problem so i reinstalled snow leopard.
    After that internet was still very slow on my iMac.
    On my Xbox 360/PS3/Ipod Touch and HTC wifi works like a charm.

    Are there things i could try to fix this issue ? Or should i send it back to apple ?
    I bought this iMac in january earlier this year.

    Greetz,
    Mick
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Can you connect the iMac to the Internet via Ethernet cable? That would show where the issues is.
     
  3. mick564 thread starter macrumors newbie

    Joined:
    Dec 18, 2010
    #3
    I can try to move the imac downstairs and connect it directly with my router.
    I'll let you know if that helps.
     
  4. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #4
    I got the other devices work OK but wouldn't it be easiest to reset the modem and router and then check before going to the trouble of relocating the iMac?
     
  5. mick564 thread starter macrumors newbie

    Joined:
    Dec 18, 2010
    #5
    I already resetted the modem and router, also i've changed the wifi channel.. i also went on my neighbours wifi network wich is also normally fast,but now also very slow.
     
  6. Drewbie macrumors member

    Joined:
    Aug 27, 2010
    #6
    if you know your wireless network name and password then go to Mac HD > library > preferences > and move the system configuration folder to the desktop.

    reboot the system and it will have reset ALL of your network connections and settings

    reconnect and test it out after that
     
  7. mick564 thread starter macrumors newbie

    Joined:
    Dec 18, 2010
    #7
    Tried it , didn't help.
    I have Applecare, but if it turn's out the mac is ok, but my router isn't are they gonna charge money for it ? Else i'm gonna call apple tomorrow to see if they can fix this issue.
     
  8. AndyMoore macrumors 6502

    AndyMoore

    Joined:
    Feb 8, 2008
    #8
    Sounds like a DNS issue to me, have you tried changing the DNS that your using to OpenDNS or Google's DNS servers?
     

Share This Page