iMac wifi very poor

Discussion in 'iMac' started by sjwvw, Dec 17, 2015.

  1. sjwvw macrumors newbie

    Joined:
    May 25, 2011
    #1
    Apologies for what is probably a much-asked question but I'm now out of ideas on how to remedy this problem. I have a 2008 iMac which, up until a few months ago, had never really had any wifi connectivity problems, at various addresses. But since I upgraded to Yosemite (I'm now on El Capitan), the connection to my home wifi is very poor indeed. Even though it often displays as a full signal, the actual internet connection is very slow, and more often than not drops away completely after a minute or so (if I'm that lucky). Not just browsing but mail, Spotify, app store etc etc.
    Now admittedly, the iMac is in my office, on the first floor of an old house, while the router is downstairs. However, an iPhone, laptop and ipad all work perfectly well in the same room, which tells me (I hope) that the problem is solely with the iMac.
    I've tried various 'fixes' through different forums, such as forgetting the network and re-entering the details, and tinkering with the network preferences (though I am little wary of this, simply because I'm no expert in this area), but I've yet to find a solution.
    I recently upgraded the RAM and installed El Capitan, not because I thought this would necessarily help, but just to ensure that the machine is running as well as it can be and there are no other performance issues to worry about.
    So...I would really appreciate any feedback and, if possible, any suggested workarounds which might help me.
    Thanks very much for any help.
     
  2. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #2
    Have you upgraded to the latest El Capitan patch, it included some bug fixes for this sort of issue???
     
  3. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    Further to the above, you can try a PRAM/SMC reset on your iMac if El Cap's fully up-to-date.

    Also ensure that your router's wireless encryption is set to WPA2-PSK (may be called WPA2-AES) only, rather than a mixed mode or WPA auto. That might do the trick.
     

Share This Page