Imac will not find external drive

Discussion in 'Mac Basics and Help' started by bigvern, Oct 11, 2009.

  1. bigvern macrumors member

    Joined:
    Jan 10, 2009
    #1
    I have recently done the upgrade to Snow Leopard and now find that my imac cannot recognise my g-tech external drive. I have messed around and got it to work once but then it will not eject. I am not sure if the upgrade is the problem or not. recently the g-tech drive seems to have constantly spinning all the time. I have tried using both firewire and USB but it is all a bit hit and miss.

    Any help would be appreciated

    I really thinking of going back to Leopard as I have not got much on my imac

    Thanks Chris UK
     
  2. Genesiscreative macrumors newbie

    Joined:
    Oct 10, 2009
    #2
    I've heard gTech drives have mount issues. It may be your drive and not SL or your Imac. Try mounting the drive on a different mac. if it mounts run disk utility.
     
  3. bigvern thread starter macrumors member

    Joined:
    Jan 10, 2009
    #3
    Tried it on my sons macbook pro and it is the same !!!!!

    It is going back to the shop tomorrow. Should have bought a Freecom had one of these for years on my windows laptop with no problem
     
  4. Genesiscreative macrumors newbie

    Joined:
    Oct 10, 2009
    #4
    Sounds like it's the drive for sure. Read the feedback on Apples website and you will see your aren't alone. I ordered a Newer Technology FireWire drive from OWC and I'm very pleased with it.
     
  5. bigvern thread starter macrumors member

    Joined:
    Jan 10, 2009
    #5
    Thanks for the advice. Struggling to find a stockist in the UK. Have you heard any feedback on wd (western digital) or iomega. Both of these are available at my local Tesco (supermarket)

    Chris
     

Share This Page