imac will not install xp home sp2 oem.

Discussion in 'Windows, Linux & Others on the Mac' started by superfrog01, Sep 10, 2009.

  1. superfrog01 macrumors newbie

    Joined:
    Sep 10, 2009
    #1
    I have a 09 imac 24. I have xp home oem disk that will not complete install. install is fine until it gets to rpcrt4.dll and shell32.dll. It will not copy either of these files. I put the same disk in my macbook and installed perfectly. I used Ntfs and fat32. No good. tried vmware fusion, and same response. apple says call windows, windows says to call mac. Help!!!!!! I have tried everything and installed in bootcamp but no. Help
     
  2. rmsowell macrumors newbie

    Joined:
    Jan 12, 2011
    #2
    OEM CD not loading

    I am having the same issues with an Windows XH Home OEM CD purchased on E-bay. It looked like the green mini-booket version with a Microsoft COA, never been used. It did not have any corporation logo (i.e. HP, DELL), only Microsoft.

    The installed would indicate that SHELL32.DL_ and RPCRT4.DL_ would not load. It must be something with the OEM CDs since I retried with a Retail copy I had and it installed perfectly.

    I need to get this OEM copy working.
     
  3. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #3
    superfrog01 never came back, so who knows if they ever solved it. The fact that it didn't load into a VM is very odd as well since that means it's not a Mac specific problem (you can't get much more "generic" hardware than a VM).

    If you can get it to install in a VM, don't activate yet, you may be able to use that to get the files in the BC partition using the same approach as outlined in the "without super drive" thread.

    EDIT: I'll spare you my OEM is not licensed for end users speech since you already bought it.

    B
     
  4. oidjio macrumors newbie

    Joined:
    Mar 16, 2011
    #4
    Same Problem

    I'm having the same problem as this post:
    http://discussions.apple.com/thread.jspa?threadID=2271517

    "I partitioned my macbook and attempted to install Windows XP

    It went well up until the 57% complete mark when the windows couldn't copy rpcrt4.dll and shell32.dll. When asked if I wanted Windows to retry to copy I hit yes and the same error occurred. When I tried to startup in WIndows got a blue-screen asking me to reinstall rpcrt4.dll"

    I tried to do what the person found successful in that thread. I copied those two files and put them into the windos folder since I formatted using the FAT. I'm not sure what to do, windows still doesn't install properly. Please help!
     

Share This Page